Results 1 to 9 of 9
  1. #1
    Join Date
    May 2003
    Posts
    847

    all sites not working when updating to centOS3.5

    HI

    all sites not working when updating to centOS 3.5

    any why to fix it ??

  2. #2
    Please provide more informations about this issue, we cannot help you with only "they doesynt work!" phrase.

    Any things in apache logs? su_exec logs? messages , secure logs?
    Apache running?

    Post more info then i try to help you out

  3. #3
    Join Date
    May 2003
    Posts
    847
    its CPANEL server

    after I update from centOS3.4 to centOS 3.5

    No site work in the server

    from WHM I found some command to run it after updating

    it shows

    [email protected] [~]# mv /etc/named.conf /etc/named.conf.CENTOS35UPDATE
    mv: overwrite `/etc/named.conf.CENTOS35UPDATE'? y
    [email protected] [~]# mv /etc/named.conf.rpmsave /etc/named.conf
    mv: cannot stat `/etc/named.conf.rpmsave': No such file or directory
    [email protected] [~]# /scripts/restartsrv_named
    [email protected] [~]#


    also when I run up2date -i -f kernel
    then rpm --import /usr/share/rhn/RPM-GPG-KEY

    it shows
    rpmdb: PANIC: fatal region error detected; run recovery
    error: db4 error(-30978) from dbenv->open: DB_RUNRECOVERY: Fatal error, run database recovery
    error: cannot open Packages index using db3 - (-30978)
    error: cannot open Packages database in /var/lib/rpm
    error: /usr/share/rhn/RPM-GPG-KEY: import failed.

  4. #4
    maybe try to rebuild RPM database from WHM , then import RPM-GPG-KEY

  5. #5
    Join Date
    Jul 2004
    Location
    Istanbul
    Posts
    58
    In root shell run:

    mv /etc/named.conf /etc/named.conf.CENTOS35UPDATE;mv /etc/named.conf.rpmsave /etc/named.conf;/scripts/restartsrv_named

    There should be a notification about this in WHM.

  6. #6

  7. #7
    Join Date
    May 2003
    Location
    Kirkland, WA
    Posts
    4,448
    If the above doesn't work, do a:

    ls -la /etc/ | grep named.conf

    Look for the larger of them, sometimes they are called named.conf.working, sometimes named.com.rpmsave, you can paste them here and we can tell you which is the right one, but it's generally the larger one, (but not named.conf,v as that's the rcs log file)

  8. #8
    Join Date
    May 2003
    Posts
    847
    Hi
    my best friend in the net solved the domains issue by checking I think file named.com.rpmsave but he said to me that
    the RPM database was broken thats why I could not run
    rpm --import /usr/share/rhn/RPM-GPG-KEY to
    up2date -i -f kernel for the new centOS 3.5

    any idea how to fix the broken RPM database ?

  9. #9
    Join Date
    May 2003
    Posts
    847
    I run

    rpm --rebuilddb

    rpm --initdb

    but no use it show error

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •