Results 1 to 14 of 14
  1. #1

    SMTP issue: Dialup connection problem

    A customer of mine (I know him IRL) is having problems sending emails using my SMTP server. When I do a Telnet to ANY smtp server (port 25) it connects but no data is sent from and to the server He has 2 different ISP's (dialup) and I tried on both of them, doesn't work, not even with the ISP's smtp server. The server is Exim btw

    I tried disabling (and checking settings in) his firewall and antivirus but that doesn't help anything.

    Any ideas? This is really strange... Thanks!

  2. #2
    Join Date
    Apr 2004
    What Dose logs say...? Telnet dosen't gurantee that everything is fine....
    Are all services necessary to Mailing are running...?
    need more info...

    Thinking Different !!

  3. #3
    Well there is nothing wrong with my mailservers I think because it works fine for anybody else... And I didn't actually try with Telnet but with a RAW connection in Putty... It connects to the mailserver, but there's just no welcome message and the server doesn't react on my commands, like the data gets lost somewhere

    What more info do you need btw?

  4. #4
    Join Date
    Sep 2002
    Chicago, Illinois
    Try running exim on port 26, many ISP's block port 25 traffic.
    Neosurge Web Services since 2002
    Neosurge VPS Hosting

  5. #5
    Join Date
    May 2005
    Try scanning his machine for spyware. I had a client with this problem a while ago and after we cleaned his machine of spyware, the problem disappeared. Might work for you, might not...

  6. #6
    I will try to run Exim on port 26 But I'm sure that the ISP is not blocking that because I already called their helpdesk and asked them about that (if was the first thing I could think of) and according to them, they don't block anything on port 25.

    Spyware hmm will do but don't think so. I checked his PC on-sight for some ad/spy ware (like msconfig, browsed some folders, registry check etc) but I'll install ad-aware and let it run. I really doubt it as he only reads email, he doesn't surf alot, and he isn't more than 5 minutes online each time (just check mail, then disconnect).

    I'll let you know what the port 26 did.

  7. #7
    Well port 26 gave the same results

  8. #8
    Join Date
    Aug 2004
    So is SMTP running for everyone else? It's just one user who can't send email?

  9. #9
    Yes, it's just one user...

  10. #10
    Join Date
    Dec 2003
    Sunny So. Calif.
    When I do a Telnet to ANY smtp server (port 25) it connects but no data is sent from and to the server
    Seems to me that since his PC cannot send/rcv to 'ANY' smtp server (I assume you mean even those which are not yours, ah you tried his ISPs as well), then the problem has to be something on his PC.

    Other than Ad-aware, you should also run Spybot, CWShredder,, possibly HiJackThis, TrojanHunter,, the list is almost endless. I often have to run 8 checks or more to find all the malicious stuff on an infected PC...

    If he is running Windows XP, make sure the Windows firewall has Port 25 open, some PCs have both that and a 3rd party firewall at the same time.

    Hmm, even when you switched to port 26 it still didn't work. Have you checked for DNS problems? Tried telnetting directly to your server IP rather than domain name?

    Hmmm, thought just kicked in, is your server using any RBLs? Maybe his dialup IPs are being blocked, possibly by rblsmtp?

    Just some suggestions

  11. #11
    Well I'll run some anti-spyware and security tools on his PC

    I disabled all firewalls while testing... Also the outgoing mail scanner from Norton AntiVirus.

    Yep tried the IP directly.

    Oh and: RBL's? That's a black-list checker, right? I don't have that installed...

    Do you think using another port, maybe 10025 or something, could work? Then I'll try that.

  12. #12
    Join Date
    Dec 2003
    Sunny So. Calif.
    Well, you've already tried port 26, wouldn't hurt to try another, but I wouldn't be hopeful that it will solve anything.

    Yes, RBL capability is often pre-installed with a given Control Panel on servers. Although I'm not familiar with your setup (assuming Cpanel/Exim)

    Have you tried Putty to the FTP port to see if you can login on the ftp port? Just for ****s & grins anyways...

    Another thing I would do is to bring the client PC to my shop and use a broadband connection to test. If the broadband connection works, but the dialup does not, then I would seriously think of his dialup ISP doing port blocking, regardless of what 1st level phone support says (often don't know their head from a hole...)

  13. #13
    Yes he's coming over today so I'll test it on my broadband connection, see if I can connect to the SMTP of my ISP. I think FTP will work, as I already used an FTP client to connect. But I will test it

  14. #14
    Join Date
    Jul 2004
    Have you looked at the exim logs?
    You are using smtp authentication...correct?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts