Results 1 to 3 of 3

Thread: cgi-bin problem

  1. #1
    Join Date
    Jun 2005
    Bundaberg, Queensland, Australia

    cgi-bin problem

    Hi I'm new to the web and have been in the proccess of setting up a server. The server is:
    AMD Processor
    VIA KM266A-Pro Based Motherboard
    VIA KT266a-Pro Chipset - 32bit AMD Processing Power
    VIA AGP Onboard Graphics - VIA AC97 audio
    DDR333 Memory 512mb
    running Fedora Core 3 and LCP (Linux control panel)

    I have set up a cgi-bin and installed an autoresponder (Proautoreply).
    When I try to bring up the autoresponder I get a 404 message. If
    I just look for I get a forbidden 403 message.
    I have changed the permissions to 775 and even 777 but still get the same message.
    Can anyone help me to fix this problem and explain what I am doing wrong.

  2. #2
    Join Date
    Nov 2004
    Hi There,

    Try to upload some test cgi scripts and access it (for exampe : ). Note that you will get this 403 permission deny error if you have enabled 'directory listing deny' in your apache or .htaccess file..
    AssistanZ - Beyond Boundaries...
    Cloudstack Consultancy / 24x7 Web Hosting Support / 24x7 Server Management / Infrastructure Management Services
    Web & Mobile Apps Development / Web Designing Services / Php, Grails, Java Development

  3. #3
    Join Date
    Feb 2002
    Vestal, NY
    Check the ownership of the cgi-bin directory as well and make sure it is assigned to the correct user/group. Generally, you want the cgi-bin to be mode 755 (or 711 in some cases).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts