trying to compile mysql 3.23.58 from source , i tried :

-felide-constructors -fno-exceptions -fno-rtti" ./configure \
--prefix=/usr/local/psa/mysql \
--localstatedir=/usr/local/psa/mysql/var  \
--with-client-ldflags=-all-static \
--with-mysqld-ldflags=-all-static \
--with-innodb=no --with-berkeley-db=no

with this previous config i am getting error with "make" :


libmysql.c: In function `mysql_real_connect':
libmysql.c:1352: warning: passing arg 5 of 
`gethostbyname_r' from incompatible pointer type
libmysql.c:1352: error: too few arguments to function `gethostbyname_r'
libmysql.c:1352: warning: assignment makes
 pointer from integer without a cast
make[2]: *** [libmysql.lo] Error 1
make[2]: Leaving directory `/root/mysql-3.23.58/libmysql'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/mysql-3.23.58'
make: *** [all] Error 2

i tried :


export CC="gcc -O3"
export CXX="gcc -O3"
./configure --prefix=/usr/local/mysql  \
--with-mysqld-ldflags=-all-static --with-mysqld-user=mysql \
--without-debug --with-innodb=no \
--with-extra-charsets=none --with-berkeley-db=no

still getting the same error !!!

i tried many times ...

the only solution i could find is to install g++ rpm ,but i do not want to do so for the sake of small binary

fedora core 3 (kernel 2.6.9-1.667)
running on vmware 4.5
no control panel

any help ?