I recently got someone to develop a system for me, as per normal once they recieved the funds they did a run an jump, Thankyou Ellery at VoIP-Host! Anyhow, I've had to work it all out myself and this problem is bugging me, can any of you lot try and give me a hand please?

I have the following in my outgoing.php file (It is using the agi-bin in asterisk)..

PHP Code:
$agi = new AGI();
$id $agi->get_var("id");
$db singleQuery("Select * from new where id = '$id'");

// Add the code for company name
$company $agi->get_var("company");
$agi->agi_exec("STREAM FILE webspaceuk/1c #");
$agi->agi_exec("STREAM FILE webspaceuk/2c #");
$agi->agi_exec("STREAM FILE webspaceuk/3c #");
// END add

$agi->agi_exec("STREAM FILE webspaceuk/2 #"); 
I recently transfered all the files over to a new server, and its all fully working except when it makes the call only 1c actually plays.

I tried deleting all the files and using this SSH command on them all :

sox 1.wav -r 8000 -c 1 1c.gsm

(I have the wavs only and have to convert them), and yet still only 1c works. I even tried converting 2c to 1c and Amazingly it worked! Although, when I place it to play 2c first, if fails.

I am honestly stumped and have tried to work it out for a few days, any of you guys got any idea's?

Thanks in advance!

James Morris