Results 1 to 4 of 4
  1. #1

    Unhappy HELP: Error with ClamAV


    Just this morning, I noticed that there was a problem with ClamAV (virus scanner with cPanel), because I received 70 emails from the service monitor.

    I tried restarting the service but this is what I get:
    [email protected] [/scripts]# ./restartsrv_clamd*
    clamd: no process killed
    clamd: no process killed
    ERROR: Can't get information about user clamav.
    I think it may be that the user account on the server has been removed, but I am not really sure. I would appreciate if anyone could help me out.

    Thanks in advance,

  2. #2
    Join Date
    Oct 2001

    Perhaps some security feature on the server removed the clamav user... my suggestion is to hire someone to find out how the account was removed - because I would be a little worried if accounts started vanishing from my severs...

    Anyway, to add the user again, try this from ssh (as root):

    groupadd clamav
    useradd -g clamav -s /bin/false -c "Clam AntiVirus" clamav
    Avi Brender
    Reliable Web Hosting by Elite Hosts, Inc
    CPANEL Reseller Hosting - Fantastico - Rvskins - ClientExec

  3. #3
    Hmm, I have worked out that ClamAV is still on the server. But when I install 'clamavconnector' on the server in addon modules in WHM, it causes the errors.

    I uninstalled and reinstalled it, now I receive this:
    [email protected] [/scripts]# service clamd start
    Starting Clam AntiVirus Daemon: ERROR: Database initialization error.     [FAILED]
    Any suggestions?


  4. #4
    Ok, the problem has been fixed, even though I don't know how.

    Thanks for your time MaB

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts