Results 1 to 2 of 2
  1. #1

    Perl problems in Webmin

    Hi Guys,

    Hopefully an easy question for some of you guru types. I have a server that im playing with webmin on (i can do a reasonable amount through the command line)

    Webmin is working. However on the MySQL databases page I get the warning:

    Warning: The Perl modules DBI and DBD::mysql are not installed on your system, so Webmin will not be able to reliably access your MySQL database. Click here to install them now.

    It then tells me to click to install, so it does. It downloads (375545 bytes) (114043 bytes)

    If I make and install I get the error :

    Executing /usr/bin/perl Makefile.PL && make ..

    Perl 5.006 required--this is only version 5.00503, stopped at Makefile.PL line 10.
    BEGIN failed--compilation aborted at Makefile.PL line 12.

    How do I fix this ? I dont really fancy messing with CPAN as I dont even know what it does!

    This machine is running FreeBSD 4.11 Stable



  2. #2
    Join Date
    Jan 2003
    Lake Arrowhead, CA
    If you're saying you want to do it from within Webmin, go to System -> Software Packages. Depending on how well Webmin supports FreeBSD, you might be able to upgrade Perl from there.

    We use Slackware, so I personally would just download the current Perl source and install it from the command line.
    Stability, redundancy and peace of mind

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts