Results 1 to 2 of 2
  1. #1
    Join Date
    May 2004

    * iptables, apf, coldfusion, imapd probles.

    Hey guys,

    I have been struggling with a problem for about a month now, if you have anything AT ALL I can try please let me know, because i have been going seriously crazy, and you will see by the length of this post, but please read on as I am extremely frustrated.

    First my system specs:
    redhat es 3.0
    dual xeon 2.8ghz
    2gb ram
    direct admin control panel
    APF/BFD (latest version)
    kernel: 2.4.21-32.0.1.ELsmp
    iptables: iptables-1.2.8-12.3
    coldfusion mx 6.1
    apache 1.3.33

    I started noticing after many stable months that coldfusion pages that use mysql would just take forever to load. Then came more reports with squirrelmail that some people were unable to load their inbox, and others complained of not being able to send attachments (you could add them to an outgoing message), but if you press send it would just take a long time and an error would come up with "server replied:" and nothing after that.

    now there are many odd fixes:
    SOMETIMES restarting httpd would fix it, sometimes restarting coldfusion would fix it. some times restart mysqld would fix it, other times restarting them all could fix it.

    However in 99% of the cases, stoping iptables (service iptables stop) would fix it and pages would instantly load, squirrelmail inboxes would load and they could send attachments.

    Now in this state, if i load any of the iptables modules (just doing iptables --list addes ip_tables and iptable_filter into the kernel as I could see with lsmod) everything would stop working again. I could restart iptables, but if i load a rule, or start apf or anything the symptoms above continue. When it gets this bad the only fix is a reboot and then apf/iptables are all running again with cf/mysql without problems, for a while.

    Now it seems to happen every night sometimes around 2AM MST other times it starts at 8am, either way it seems late at night but appears quite random.

    I checked my logs for anything running around that time but I can't find anything that seems like a pattern.

    For the life of me i can't reproduce the problem.

    I tried running run-parts /etc/cron.daily
    I tried hammering my coldfusion pages with load testers
    I tried starting and stopping apf over and over.

    I upgraded APF/BFD to latest version after this started happening (did an upgrade and a complete fresh install from scratch)
    I upgraded coldfusion and recompiled the apache connector.
    I have just now removed the iptables rpm and reinstalled it.

    Although I can't fully remember this may have happend after a kernel upgrade.

    Anyhelp or suggestions would be extremely appreciated.

    Thank you for your time.

  2. #2
    Join Date
    May 2004
    oh yeah, this is coldfusion mx 6.1

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts