Results 1 to 6 of 6

Thread: chmod problems

  1. #1
    Join Date
    Oct 2004
    Location
    Israel
    Posts
    70

    chmod problems

    I just started learning Perl/CGI and I seem to have a problem.
    I created a perl test file (test.cgi), and then uploaded it to my server and changed permissions to 755. For some reason, it forces me to do the chmod each time I edit the file and upload it. (Otherwise it dies with Internal Server Error. See full error message below)
    I tried to do chmod to the source file on my local machine in Konsole, but it wouldn't solve the problem. I'm still forced to do chmod each time I edit and upload the file.

    How could I solve it?

    Thanks

    (Mandrake linux 9.2, uploading and doing chmod with gftp)

    The error message:
    "Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request. "
    Last edited by Northern; 06-04-2005 at 01:16 PM.

  2. #2
    Join Date
    Jul 2004
    Posts
    378
    Sounds like it may be a problem with your ftp program. That's really strange. I have never heard this of happening.

  3. #3
    Join Date
    Oct 2004
    Location
    Israel
    Posts
    70
    I tried to upload with kbear and the same problem accrued.
    Any more ideas?

  4. #4
    I think it would be a problem with the server side ftp program. Once you upload the file the server probably replaces it and you lose the previous file security settings.

  5. #5
    Join Date
    Mar 2004
    Posts
    1,301
    try to upload the file in ASCII mode. do not use auto ...see if it works.

  6. #6
    Join Date
    Oct 2004
    Location
    Israel
    Posts
    70
    Oh, it worked.
    Thanks everyone.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •