Results 1 to 8 of 8
  1. #1
    Join Date
    May 2003
    Posts
    847

    I get red ball in Service Status from WHM

    Hi

    I have cpanel server

    I get red ball in Service Status from WHM

    for (BIND)

    but in fact I can see it runing from SHELL and all domains working well

    Also I get this email

    Status warning from host.domain.com

    System integrity monitor on host.domain.com has taken action in responce to an event. Recent event logs are enclosed below for your inspection. There has been 38 events today, if an average of 8 events is reached, e-mail alerts will be terminated for the duration of the day.

    - Events Summary:
    Total event count: 38
    Average event count: 7

    - Service Summary:
    FTP [online - 0 events]
    HTTP [online - 0 events]
    DNS [restarted - 38 events]
    MYSQL [online - 0 events]
    SMTP [online - 0 events]

    - System Summary:
    No system modules enabled - edit conf.sim


    Any idea ??

  2. #2
    Join Date
    Jun 2000
    Location
    Washington, USA
    Posts
    5,991
    Try running 'ndc status' as root. If it gives an authentication error, or some such, do '/scripts/fixndc'

  3. #3
    Join Date
    Feb 2004
    Posts
    772
    hi,

    use sim -c
    to correct this problem. Its not really a problem per say, only that your run SIM manualy while the cronjob trys to run.

    Add the following to, /etc/cron.hourly/sim

    #!/bin/sh
    rm -f /var/lock/subsys/sim

    then chmod 711 the file
    [[email protected] ~]# chmod 711 /etc/cron.hourly/sim
    Bright Info Solutions

  4. #4
    Join Date
    May 2003
    Posts
    847
    thank you for replaying

    but bind (9.2.4) shows failed

    and I can not access domains

    when I restart it shows this

    [email protected] [~]# /etc/init.d/named restart
    Stopping named: [FAILED]
    Starting named: [ OK ]
    [email protected] [~]#

  5. #5
    Join Date
    Feb 2004
    Posts
    772
    hi,

    check this in:

    /usr/local/sim/modules/init/httpd.mod

    set socket_chkapp=0

    For any other service that is falsely failing due to failed socket check -- edit it module and disable socket_chkapp.
    Bright Info Solutions

  6. #6
    Join Date
    May 2003
    Posts
    847
    /usr/local/sim/modules/init/httpd.mod

    No such file or directory

  7. #7
    Join Date
    May 2003
    Posts
    847
    today the domains not whoking one the server until I restart named and it shows this

    [email protected] [~]# /etc/init.d/named restart
    Stopping named: [FAILED]
    Starting named: [ OK ]
    [email protected] [~]#

  8. #8
    Join Date
    May 2003
    Posts
    847
    I fix the problem by reinstalling BIND

    but from time to time the domains not working and when I run
    [email protected] [~]# /etc/init.d/named restart
    Stopping named: [FAILED]
    Starting named: [ OK ]
    [email protected] [~]#

    then the domains working its to hard to restart Service if there is away to solve it

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •