Results 1 to 2 of 2
  1. #1
    Join Date
    Jun 2004
    Posts
    523

    cpanel and named

    currently named is by default started with the command "named" by cpanel which breaks named due to permissions.

    how do i change this so cpanel starts named with "named -u"? any ideas?

  2. #2
    Join Date
    Oct 2004
    Location
    India
    Posts
    80
    Check the /etc/init.d/named file end edit it accordingly.

    The start() function can be quite like this.

    Code:
    start() {
            # Start daemons.
            if [ -n "`/sbin/pidof named`" ]; then
                    echo -n $"$prog: already running"
                    return 1
            fi
            echo -n $"Starting $prog: "
            if [ -n "${ROOTDIR}" -a "x${ROOTDIR}" != "x/" ]; then
                    OPTIONS="${OPTIONS} -t ${ROOTDIR}"
            fi
            daemon /usr/sbin/named -u named ${OPTIONS}
            RETVAL=$?
            [ $RETVAL -eq 0 ] && touch /var/lock/subsys/named
            echo
            return $RETVAL
    AssuredHost.Com
    Secured Shared and Reseller Web hosting Solutions
    We Host Your Trust

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •