Results 1 to 10 of 10
  1. #1
    Join Date
    May 2005
    Posts
    53

    authorization denied

    I can't gained access to my server anymore. I used to be able to no problem, but now, all of a sudden, everytime I try to connect with http://localhost/, http://192.168.1.105, or the ip address of my router (determined by www.whatismyipaddress.com) with port forwarding setup, I get this message:

    You are not authorized to view this page

    You do not have permission to view this directory or page using the credentials that you supplied.
    .
    .
    .
    HTTP Error 401.1 - Unauthorized: Access is denied due to invalid credentials. Internet Information Services (IIS).
    .
    .
    .

    I have my c:\Inetpub\wwwroot\ directory set to sharing and web sharing, and all permissions for all users are set to full control. I'm running Windows Server 2003 Web Edition, and working within an office network.

    It never used to do this, so why now?

    Here is a list of things I did between the last time I had access and the first time I encountered this permission denied message:

    - created a new user with his own FTP account.
    - Rebooted computer
    - noticed router's IP address has changed to 24.71.223.140 (I know that I should have a static IP for hosting, but I haven't done that yet).
    - reconfigured port forwarding to 192.168.1.105 on port 80.
    - noticed router ip address changed back to what it was before: 68.144.5.14

    Any ideas?

  2. #2
    Join Date
    Nov 2004
    Location
    Leeds, UK
    Posts
    254
    Hello,

    You need to set up the site in IIS aswell. Not just the web sharing. Go into IIS and right click on the default website. Then, click directory security. Then, you need to enable anonymous access control to suit your needs.

    Let me know if this helps,

    Matt
    Matt Midgley
    ----------------
    http://matt.midgley.name

  3. #3
    Join Date
    May 2005
    Posts
    53
    Thanks, your advice worked. I checked Integrated Windows authentication, and left everything else unchecked, and that worked.

    However, I'm still having trouble connecting through my router. http://localhost/ and http://192.168.1.105/ both work, but using the ip address of my router still does not. I tells me:

    The page cannot be displayed
    .
    .
    .
    HTTP 500 - Internal server error
    Internet Explorer

    I've got port forwarding setup and I'm making sure I'm using the right ip address by checking it at www.whatismyipaddress.com everytime I try to connect. The router used to work and I used to be able to connect from home. Would the fact that the ip address is not static have anything to do with it?

  4. #4
    Join Date
    Nov 2004
    Location
    Leeds, UK
    Posts
    254
    Glad I could help.

    When connecting through your router, I assume it's from a location other than where the server is? I used to run a server on a connection with a dynamic IP address. I solved the problem by using the no-ip.com service which automatically updates your IP to a domain name.

    Regards,
    Matt
    Matt Midgley
    ----------------
    http://matt.midgley.name

  5. #5
    Join Date
    May 2005
    Posts
    53
    So, are you saying that registering a domain name will make me authorized to view my pages?

  6. #6
    Join Date
    Oct 2002
    Posts
    5,177
    Turn off Friendly HTTP errors in Internet Explorer.

    Go to Tools, Internet Options, Advanced, and uncheck "Show Friendly HTTP Error messages". Then reload the page. You'll still get the "500" error, but it will output a more detailed error that will provide a better clue as to what's going on. Post that error here please.
    If you have to operate your company behind the scenes or under a fake name, maybe it's time to leave the industry and start something fresh.

  7. #7
    Join Date
    May 2005
    Location
    Canada
    Posts
    15
    Some providers block port 80 to stop peopel from running webservers. If you have any other servers running on different ports, you could try accessing them with the outside ip to see what they do.

  8. #8
    Join Date
    May 2005
    Posts
    53
    Ok, after turning off Friendly HTTP Error messages, it says:

    Server Error

    The following error occurred:

    [code=CANT_CONNECT_LOOPBACK] Cannot connect due to potential loopback problems

    -----------------------------------------------------------------------------------

    Please contact the administrator.

    I have no idea what this means.

  9. #9
    Originally posted by coryd
    Some providers block port 80 to stop peopel from running webservers. If you have any other servers running on different ports, you could try accessing them with the outside ip to see what they do.
    Thats highly unlikely as he is accessing it from localhost.

    Ok, after turning off Friendly HTTP Error messages, it says:

    Server Error

    The following error occurred:

    [code=CANT_CONNECT_LOOPBACK] Cannot connect due to potential loopback problems

    -----------------------------------------------------------------------------------

    Please contact the administrator.

    I have no idea what this means.


    It clearly can't connect to the loopback (internal) network address for some reason or another. Try going to start > run > type "cmd" then in the msdos interface type "ipconfig" the returned IP will be your localhost, try accessing from this. Alternatively, some aspect of your automatic host records are setup wrong, you may want to try a reinstall of the network card drivers and set the statick IP's.

    I apologise if I'm stating the obvious, I am used to resolving problems with linux servers
    BeeServe
    * Rock solid shared & reseller UK webhosting. No downtime™ *
    Now offering fully managed VPS servers

  10. #10
    Join Date
    May 2005
    Location
    Canada
    Posts
    15
    He posted the one above mine just after I was posting

    He's said localhost works, it's only when he tries with his real (external) ip that it doesn't work.

    Do you have the server setup for multiple hostnames perhaps?

    As long as you have the proper ip address, the port is forwarded properly and the machine that is actually serving the webpages is setup, dynamic or static ips won't matter for testing, just for actual outside use you will need some method of getting the current ip out to anyone that would be visiting your page.

    Does your router have a web based setup that uses port 80? You could try forwarding a different port on the router to port 80 on the webserver and seeing what that does when you access it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •