Results 1 to 9 of 9
  1. #1
    Join Date
    Apr 2002
    Posts
    77

    pure-ftpd not working with apf

    i installed apf and pure-ftpd and now when i connect to ftp it connects okay but "LIST" command just locks up. when doing from command line ftp -- it says entering passive mode and then do "LIST" then hangs up there. (btw i have not passive in my ftp client)

    in my pure-ftpd.conf i set passiveportrange to 30000 35000
    and updated conf.apf to allow incoming tcp at that range aswell (30000_35000)

    any ideas ?
    Every line ends in rhyme

  2. #2
    i think you need passive with your ftp client to make it working.

    Check filezilla or fireftp ( a firefox extension )...

  3. #3
    Join Date
    Nov 2004
    Location
    India
    Posts
    1,100
    Have you opened outbounding ports 20, 21 in your apf firewall?
    AssistanZ - Beyond Boundaries...
    Cloudstack Consultancy / 24x7 Web Hosting Support / 24x7 Server Management / Infrastructure Management Services
    Web & Mobile Apps Development / Web Designing Services / Php, Grails, Java Development

  4. #4
    Join Date
    Apr 2002
    Posts
    77
    not working even in passive mode
    Every line ends in rhyme

  5. #5
    Join Date
    Apr 2002
    Posts
    77
    great it was missing port 20.

    thank you
    Every line ends in rhyme

  6. #6
    Join Date
    Sep 2002
    Location
    Top Secret
    Posts
    11,687
    Pure-ftp will work quite well using APF, I'm running both, and have no problems whatsoever.
    Make sure you've opened port 21 (20 isn't necessary) in apf, both incoming and outgoing and you'll be good to go.
    WHMCS Guru - WHMCS addons, management, support and more.
    WHMCS Notifications Extended - Add slack, hipchat, SMS, pushover to WHMCS !!
    Always looking for Linux, WHMCS, Support Desk work. PM for details

  7. #7
    Join Date
    Apr 2002
    Posts
    77
    alright its not working again.

    my client say cannot open data connection to 3331 (or similiar) (during LIST command)

    that seem to me like something wrong with the passive port settings, those are set to 35000-36000 in pureftpd and as incoming ports in apf

    any ideas ?
    Every line ends in rhyme

  8. #8
    Join Date
    Apr 2002
    Posts
    77
    i just find out, it works when i have #Bind commented out, so its listening to all IPs / port 21
    but i want to have it bound to other port say 12345, when i bind it to : 1.2.3.4,12345 it dont work anymore when apf is running. 12345 open for out/in in apf.
    Every line ends in rhyme

  9. #9
    Join Date
    Apr 2002
    Posts
    77
    i added my IP to with apf -a and it work now.
    Every line ends in rhyme

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •