Results 1 to 7 of 7
  1. #1

    Do I need to add "www" as an alias for subdomains?

    Hi:
    I've just set up a subdomain that's hosted on a different server, using a A record in WHM. One problem I've noticed is that if I type:

    http://test.domain.com/dir

    instead of:

    http://test.domain.com/dir/ (trailing slash)

    I get a page not found. My guess is without the slash, it tries to go to http://www.test.domain.com

    How would I solve this problem? Add "www.test" as a A record as well to redirect to the actual IP?

    Thanks,

  2. #2
    Join Date
    Mar 2005
    Posts
    57
    Hi!

    I think you'll have to have an alias for 'www' as well, or simply use wildcard like:

    *.sub.domain.com

  3. #3
    Join Date
    Feb 2004
    Posts
    772
    hai easybyte,

    You may try adding test.domain.com as a domain alias with "Create DNS Zone" and "New Mail Domain Alias" options unchecked.

    For help in creating domain aliases,plz visit:

    http://psoft.net/HSdocumentation/use...omain_aliasing

    thanks
    Bright Info Solutions

  4. #4
    Join Date
    Feb 2004
    Posts
    772
    hai easybyte,

    for more details plz visit this link.

    http://www.megahosters.com/docs/configuring_domains.php

    thanks
    Bright Info Solutions

  5. #5
    Join Date
    Feb 2005
    Posts
    334
    Thats actually an apache setting. I dont recall off the top of my head which it is, but check your indexes/directory options in httpd.conf or .htaccess. You can also use mod_rewrite to change this behavior, but Im blanking on the exact cause at the moment...

    Also check how your aliases are set up as I believe this can cause it also according to your config

  6. #6
    Here's a link to the rewrite guide for Apache. http://httpd.apache.org/docs/misc/rewriteguide.html

    Specifically, look at the section titled "Trailing Slash Problem".
    Game control panels - control your game world your way. Server-Genie.com
    http://www.server-genie.com

  7. #7
    I actually solved my problem by just adding:

    www.test.mysite.com

    as a 2nd A record redirect, instead of just test.mysite.com That took care of the problem, as apparently without a trailing slash, the server tries to go to www.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •