Results 1 to 9 of 9
  1. #1
    Join Date
    Jul 2003
    Location
    Vancouver
    Posts
    161

    Virtual Hosting + Apache + SuExec problem

    I get a 403 forbidden error when trying to access media.fungod.com
    Apache is set to run under user apache

    Error-log report:
    [Fri Apr 29 21:52:24 2005] [error] [client 24.85.134.45] (13)Permission denied: access to / failed because search permissions are missing on a component of the path


    I Have configured and install suexec: It loads
    [Fri Apr 29 21:45:30 2005] [notice] suEXEC mechanism enabled (wrapper: /usr/local/apache/bin/suexec)

    This is my Apache vh config:
    NameVirtualHost 70.85.111.139:80

    <VirtualHost 70.85.111.139:80>
    ServerName media.fungod.com
    ServerAdmin [email protected]
    DocumentRoot /home/fungod/html
    ServerName media.fungod.com
    ErrorLog logs/fungod.com-error_log
    CustomLog logs/fungod.com-access_log common
    </VirtualHost>

  2. #2
    Join Date
    Jan 2004
    Posts
    445
    Look to be missing a Server Alias directive.
    ServerAlias media.fungod.com www.media.fungod.com

  3. #3
    Join Date
    Jul 2003
    Location
    Vancouver
    Posts
    161
    I'm still getting the 403 forbidden error.

  4. #4
    Join Date
    Apr 2004
    Location
    SF Bay Area
    Posts
    877

    Re: Virtual Hosting + Apache + SuExec problem

    Originally posted by Rclark
    (13)Permission denied: access to / failed because search permissions are missing on a component of the path

    <VirtualHost 70.85.111.139:80>
    DocumentRoot /home/fungod/html
    </VirtualHost>
    So what are the permissions and ownership of /home/fungod/html? Are /home and /home/fungod at least 775? Is /home/fundgod/html 775 and owned by apache?

    Sorry if I'm insulting your intelligence--just curious if the error is describing an exact problem on the filesystem (i.e., it's being literal) or if it's another problem.

    I Have configured and install suexec: It loads
    [Fri Apr 29 21:45:30 2005] [notice] suEXEC mechanism enabled (wrapper: /usr/local/apache/bin/suexec)
    Hmmm... how is this related to the problem above? Suexec is used to exec CGI binaries safely in a user's personal WWW/public_html directory is it not?

  5. #5
    What OS/ distribution, kernel are you running?

  6. #6
    Join Date
    Jul 2003
    Location
    Vancouver
    Posts
    161
    RH ES 3 with the latest kernel.

    I thought suexec might be causing problems with my predefined User/Group defines in my <VirtualHost> tag.

    But I'm just not sure why it isn't reading the index.html in /home/fungod/html

  7. #7
    Join Date
    Jul 2003
    Location
    Vancouver
    Posts
    161
    I fixed it ! Woot. thanks for the replies people. you rock

  8. #8
    Join Date
    Jan 2004
    Posts
    445
    Originally posted by Rclark
    I fixed it ! Woot. thanks for the replies people. you rock
    Care to share with us what the fix was?

  9. #9
    Join Date
    Jul 2003
    Location
    Vancouver
    Posts
    161
    /home/fungod wasn't 755

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •