We have been having some RAID issues with one of our machines in particular. Now I added a site today and the server hung up, we then tried to reboot the machine from the LCD panel and it just sat there. So we did a hard boot and hit the power button.

So now since the site was "half-way" setup it does not show up in the GUI but shows up when I SSH onto the server. I tried resetting up the website through the GUI and now get an error:

Sorry, an error occurred while trying to create an email server map file. If mail server configuration files were removed or manually modified, please restore the original versions and try again.

I have done some research on this topic and it appears that maybe I need to rebuild the "/etc/mail/virtusertable", but how do I do that? Is that even the problem?

There is a backup of "virtusertable" which is 65767 bytes in size, while the "virtusertable" that is being used is 65793 bytes in size.

This all happened when the site was almost setup but then the server hung up for whatever reason.

Does anyone have any ideas?

When I pico the virtusertable I see this:


When I do the "diff" command I get this:

Binary files virtusertable and virtusertable.backup.1 differ

When I try running that command you sent I get this:

make: Entering directory `/etc/mail'
make: *** No targets specified and no makefile found. Stop.
make: Leaving directory `/etc/mail'

Any idess?

Any help would be great as no user on the server can get email. We are in the process of moving sites off to another server but since we have so many its taking forever.

Thanks in advance for your help