Results 1 to 6 of 6
  1. #1

    * I dug a big hole in sendmail and I am not sure how to get out - HELP!

    hhhmmm need some HHHEELLLPP!

    Hi yes I have the same problem. I lot of hosts, ISP's etc are joining orbs which basically blocks any email that is relayed.

    I was trying to solve this problem as per what orbs say on their site at orbs sendmail which is to include the following line in my sendmail.mc

    FEATURE(`dnsbl', `relays.ordb.org', `Rejected - see http://ordb.org/')dnl

    Anyway when I pico into sendmail.mc it has the following info at the top.

    dnl This is the sendmail macro config file. If you make changes to this file,
    dnl you need the sendmail-cf rpm installed and then have to generate a
    dnl new /etc/sendmail.cf by running the following command:
    dnl
    dnl m4 /etc/mail/sendmail.mc > /etc/sendmail.cf

    So of course I take note of this and write it down. I then went and had a quick look at sendmail.cf before touching sendmail.mc and I noted that it was a special ensim version. Also on a check for sendmail-cf rpm I came up with sendmail-cf-8.11.6-2ensim3. (But I did not save a copy of sendmail.cf......)

    Ok so I think I am sweet. I have all the correct modules, etc so I think lets go ahead and give it a burl.

    So I pico into sendmail.mc and make the change adding the line FEATURE(`dnsbl', `relays.ordb.org', `Rejected - see http://ordb.org/')dnl
    at the end of the Features list.

    Then I m4 /etc/mail/sendmail.mc > /etc/sendmail.cf and then using ensim I try and restart SMTp.........nothing, no restart

    Mild panic starts to set in so I pico back to sendmail.mc and delete what I have just added.....then I
    m4 /etc/mail/sendmail.mc > /etc/sendmail.cf
    again and back into ensim and restart SMTP.....it works...... Phew I think.

    So lets go and send some test emails......nothing received, nothing can be sent......Greater panic now.

    I think the thing I stuffed up most is by not saving a copy of sendmail.cf. I think what has happended is that by doing m4 /etc/mail/sendmail.mc > /etc/sendmail.cf
    I have overwritten the special ensim version with a standard sendmail version and while I seem to be still able to access sendmail from ensim, I can no longer send or receive email.

    Can someone possibly help me out of this predicament I have gotten myself into????????? I am assuming that thier is a module that I can possibly run to restore the settings??????

  2. #2
    Join Date
    Oct 2001
    Location
    san diego
    Posts
    256
    what did ensim say?

  3. #3
    No response as yet....I will try their forums.

    Anyone have some ideas?

  4. #4
    Try the attachment below it is the default sendmail.cf file for Ensim 3.0.

    Replace the one you have with this one and see if it fixes the problem. After replacing restart the webppliance.
    Attached Files Attached Files
    Regards,
    Brian P.
    Digital X Web[TM], LLC
    http://digitalxweb.net

  5. #5
    Thanks digital. Chris on the ensim pointed out that ensim have a separate sendmail.mc file so the theory was correct, I just edited the wrong file.

    ok here is the solution.....so far. I am still testing and getting some relaying denied problems but here goes.

    To ad orbs to your sendmail.

    Log into root through SSH.

    Once there

    cd /usr/lib/opcenter/sendmail/install

    ok now we need to edit sendmail.mc

    pico sendmail.mc

    page down until you see a list of FEATURES

    At the end of FEATURES and before EXPOSED add the line

    FEATURE(`dnsbl', `relays.ordb.org', `Rejected - see http://ordb.org/')dnl

    then control x to exit pico

    Y to save and then press enter to save file.

    Ok now we need to update sendmail.cf

    so now go

    m4 /usr/lib/opcenter/sendmail/install/sendmail.mc > /etc/sendmail.cf

    Now that is it....it should be done. I am still testing this but for anyone following this thread this is the solution so far. The problem previously is that I had simply edited the wrong sendmail.mc. Thanks to Chris on the ensim board for pointing this out. The thread at ensim for those interested is Ensim thread

  6. #6
    Good to see you have it fixed..
    Regards,
    Brian P.
    Digital X Web[TM], LLC
    http://digitalxweb.net

  7. Newsletters

    Subscribe Now & Get The WHT Quick Start Guide!

Related Posts from theWHIR.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •