Results 1 to 11 of 11
  1. #1
    Join Date
    Jan 2005
    Location
    UK
    Posts
    1,370

    PHP version not updating in CPanel

    I recently upgraded my PHP version. In WHM, i went to "Update Apache", unchecked the previous version and checked the new version, then started the build. It was successful, and if I run phpinfo() it says the correct version, but CPanel has not updated to read this new version.

    Any idea of what i need to do to update it there?

    Thanks,

    Brandon

  2. #2
    Join Date
    Jul 2001
    Location
    Troy, Missouri USA
    Posts
    1,299
    What OS are you running, I know Centos has a few issues that can be corrected.

  3. #3
    Join Date
    Jan 2005
    Location
    UK
    Posts
    1,370
    Running Redhat 9

  4. #4
    Join Date
    Mar 2003
    Location
    California USA
    Posts
    13,250
    /scripts/makecpphp from ssh
    Steven Ciaburri | Proactive Linux Server Management - Rack911.com
    System Administration Extraordinaire | Follow us on twitter:@Rack911Labs
    Managed Servers (AS62710), Server Management, and Security Auditing.
    www.HostingSecList.com - Security notices for the hosting community.

  5. #5
    Join Date
    Jan 2005
    Location
    UK
    Posts
    1,370
    What exactly does this do? I'm running it now; I'll let you know the results.

  6. #6
    Join Date
    Mar 2003
    Location
    California USA
    Posts
    13,250
    it compiles the cpanel version of php.. but what version of php are you trying to use? cpanel php does not support 5
    Steven Ciaburri | Proactive Linux Server Management - Rack911.com
    System Administration Extraordinaire | Follow us on twitter:@Rack911Labs
    Managed Servers (AS62710), Server Management, and Security Auditing.
    www.HostingSecList.com - Security notices for the hosting community.

  7. #7
    Join Date
    Jan 2005
    Location
    UK
    Posts
    1,370
    Then why is 5.0.3 available in whm? I was trying to test out php5, and it works but cpanel like I said did not update.

    the command is still running.

  8. #8
    Join Date
    Mar 2003
    Location
    California USA
    Posts
    13,250
    Apache will use 5.0.3, but cpanel will use 4.0.10
    Steven Ciaburri | Proactive Linux Server Management - Rack911.com
    System Administration Extraordinaire | Follow us on twitter:@Rack911Labs
    Managed Servers (AS62710), Server Management, and Security Auditing.
    www.HostingSecList.com - Security notices for the hosting community.

  9. #9
    Join Date
    Jan 2005
    Location
    UK
    Posts
    1,370
    Just as a clarification, what does CPanel use 4.3.10 for; I mean when is CPanel's version used?

    Any idea on when CPanel will be able to use 5.0.3?

  10. #10
    Join Date
    Mar 2003
    Location
    California USA
    Posts
    13,250
    5.0.3 is not compatable with cpanels internal scripts and stuff.
    Steven Ciaburri | Proactive Linux Server Management - Rack911.com
    System Administration Extraordinaire | Follow us on twitter:@Rack911Labs
    Managed Servers (AS62710), Server Management, and Security Auditing.
    www.HostingSecList.com - Security notices for the hosting community.

  11. #11
    Join Date
    Jan 2005
    Location
    UK
    Posts
    1,370
    Ah i see; thank you for the explanation.

Related Posts from theWHIR.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •