Results 1 to 6 of 6

Thread: libXpm Missing

  1. #1

    libXpm Missing

    Hi,

    I'm trying to recompile PHP w/ GD2 installed, but I'm getting the following error in easyapache:

    configure php-4.3.9...(--with-apxs=/usr/local/apache/bin/apxs --with-xml --enable-bcmath --enable-calendar --enable-ftp --with-gd --with-jpeg-dir=/usr/local --with-png-dir=/usr --with-xpm-dir=/usr/X11R6 --with-mcrypt --enable-magic-quotes --with-mysql --enable-discard-path --with-pear --enable-sockets --enable-track-vars --with-ttf --enable-versioning --with-zlib)...............Done
    configure: error: libXpm.(a|so) not found.

    How can I get libXpm installed? I already tried re-installing the XFree86-libs RPM in WHM.

    What else can I do ot get this library installed?

    Usiing Fedore Core 1 w/ WHM/Cpanel

    Thanks.

  2. #2
    Join Date
    May 2003
    Location
    Colorado Springs, Colorado
    Posts
    34
    A great resource for finding missing libraries or tools is at rpmfind dot net. You can just enter libXpm and it will return a list of RPMs.

    <<< Signatures need to be set up in your profile. >>>
    Last edited by SoftWareRevue; 03-01-2005 at 01:07 PM.

  3. #3
    How would I install that?

    Like this:

    rpm -i libXpm-4.3.99.903-2.i686.rpm

    ???

    And do I need to restart the server after the installation?

    Thanks

  4. #4
    Help, anyone? :T

  5. #5
    Join Date
    Jan 2004
    Location
    /home/dislexik
    Posts
    820
    rpm -i libXpm-4.3.99.903-2.i686.rpm

    Yes, I actually do:

    rpm -Uvh rpmname.rpm

    Firstly if it is already installed it updates it otherwise installs it, and it gives you verbose output and a # (hash) percentage of installation progress..

    DislexiK
    "You donít learn to hack, you hack to learn"

  6. #6
    Thanks, but I got the following error(s) after that:

    root@matrix [~]# rpm -Uvh libXpm-4.3.99.903-2.i686.rpm
    warning: libXpm-4.3.99.903-2.i686.rpm: V3 DSA signature: NOKEY, key ID e01260f1
    error: Failed dependencies:
    libICE.so.6 is needed by (installed) startup-notification-0.5-2
    libICE.so.6 is needed by (installed) memprof-0.5.1-3
    libICE.so.6 is needed by (installed) ghostscript-7.07-11
    libICE.so.6 is needed by (installed) gnome-python2-2.0.0-2
    libICE.so.6 is needed by (installed) libgnomeui-2.4.0.1-1
    libICE.so.6 is needed by (installed) emacs-21.3-7
    libICE.so.6 is needed by (installed) Xaw3d-1.5-19
    libICE.so.6 is needed by (installed) oprofile-0.7cvs-0.20030829.6
    libICE.so.6 is needed by (installed) libwnck-2.4.0.1-1
    libICE.so.6 is needed by (installed) libbonoboui-2.4.0-1
    libICE.so.6 is needed by (installed) usermode-gtk-1.69-1
    libICE.so.6 is needed by (installed) qt-3.1.2-14
    libSM.so.6 is needed by (installed) startup-notification-0.5-2
    libSM.so.6 is needed by (installed) memprof-0.5.1-3
    libSM.so.6 is needed by (installed) ghostscript-7.07-11
    libSM.so.6 is needed by (installed) gnome-python2-2.0.0-2
    libSM.so.6 is needed by (installed) libgnomeui-2.4.0.1-1
    libSM.so.6 is needed by (installed) emacs-21.3-7
    libSM.so.6 is needed by (installed) Xaw3d-1.5-19
    libSM.so.6 is needed by (installed) oprofile-0.7cvs-0.20030829.6
    libSM.so.6 is needed by (installed) libwnck-2.4.0.1-1
    libSM.so.6 is needed by (installed) libbonoboui-2.4.0-1
    libSM.so.6 is needed by (installed) usermode-gtk-1.69-1
    libSM.so.6 is needed by (installed) qt-3.1.2-14
    libX11.so.6 is needed by (installed) startup-notification-0.5-2
    libX11.so.6 is needed by (installed) gtk2-2.2.4-5.1
    libX11.so.6 is needed by (installed) redhat-config-proc-0.23-1
    libX11.so.6 is needed by (installed) libungif-4.1.0-16
    libX11.so.6 is needed by (installed) ghostscript-7.07-11
    libX11.so.6 is needed by (installed) pango-1.2.5-1.1
    libX11.so.6 is needed by (installed) XFree86-Mesa-libGL-4.3.0-42
    libX11.so.6 is needed by (installed) XFree86-xfs-4.3.0-42
    libX11.so.6 is needed by (installed) VFlib2-2.25.6-18
    libX11.so.6 is needed by (installed) XFree86-xauth-4.3.0-42
    libX11.so.6 is needed by (installed) gdk-pixbuf-0.22.0-3.0
    libX11.so.6 is needed by (installed) emacs-21.3-7
    libX11.so.6 is needed by (installed) Xaw3d-1.5-19
    libX11.so.6 is needed by (installed) oprofile-0.7cvs-0.20030829.6
    libX11.so.6 is needed by (installed) libwnck-2.4.0.1-1
    libX11.so.6 is needed by (installed) libbonoboui-2.4.0-1
    libX11.so.6 is needed by (installed) usermode-gtk-1.69-1
    libX11.so.6 is needed by (installed) qt-3.1.2-14
    libXext.so.6 is needed by (installed) gtk2-2.2.4-5.1
    libXext.so.6 is needed by (installed) redhat-config-proc-0.23-1
    libXext.so.6 is needed by (installed) ghostscript-7.07-11
    libXext.so.6 is needed by (installed) XFree86-Mesa-libGL-4.3.0-42
    libXext.so.6 is needed by (installed) XFree86-xfs-4.3.0-42
    libXext.so.6 is needed by (installed) VFlib2-2.25.6-18
    libXext.so.6 is needed by (installed) XFree86-xauth-4.3.0-42
    libXext.so.6 is needed by (installed) gdk-pixbuf-0.22.0-3.0
    libXext.so.6 is needed by (installed) emacs-21.3-7
    libXext.so.6 is needed by (installed) Xaw3d-1.5-19
    libXext.so.6 is needed by (installed) qt-3.1.2-14
    libXfont.so.1 is needed by (installed) XFree86-xfs-4.3.0-42
    libXfont.so.1 is needed by (installed) XFree86-font-utils-4.3.0-42
    libXft.so.2 is needed by (installed) gtk2-2.2.4-5.1
    libXft.so.2 is needed by (installed) pango-1.2.5-1.1
    libXft.so.2 is needed by (installed) qt-3.1.2-14
    libXi.so.6 is needed by (installed) gtk2-2.2.4-5.1
    libXi.so.6 is needed by (installed) redhat-config-proc-0.23-1
    libXi.so.6 is needed by (installed) gdk-pixbuf-0.22.0-3.0
    libXmu.so.6 is needed by (installed) emacs-21.3-7
    libXmu.so.6 is needed by (installed) Xaw3d-1.5-19
    libXmu.so.6 is needed by (installed) qt-3.1.2-14
    libXmuu.so.1 is needed by (installed) XFree86-xauth-4.3.0-42
    libXrandr.so.2 is needed by (installed) gtk2-2.2.4-5.1
    libXrandr.so.2 is needed by (installed) qt-3.1.2-14
    libXrender.so.1 is needed by (installed) gtk2-2.2.4-5.1
    libXrender.so.1 is needed by (installed) pango-1.2.5-1.1
    libXrender.so.1 is needed by (installed) qt-3.1.2-14
    libXt.so.6 is needed by (installed) ghostscript-7.07-11
    libXt.so.6 is needed by (installed) emacs-21.3-7
    libXt.so.6 is needed by (installed) Xaw3d-1.5-19
    XFree86-libs = 4.3.0-42 is needed by (installed) XFree86-xfs-4.3.0-42
    XFree86-libs >= 4.2.99 is needed by (installed) libgnomeui-2.4.0.1-1
    root@matrix [~]#

    What else can I do?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •