Results 1 to 10 of 10
  1. #1
    Join Date
    Jun 2001
    Location
    South Carolina, USA
    Posts
    90

    Apache hides .htpasswd directories

    How can I stop apache (2.0) from hiding .htpasswd directories in directory listings?

    For example, I have the following setup:
    site.net/blah/ contains a directory listing of random files and folders.
    site.net/blah/cool/ is a folder with a .htpasswd on it.

    My problem is that the directory listing in site.net/blah/ will not contain site.net/blah/cool/ unless the user is auth'ed to view site.net/blah/cool/

    In the case of my site, where the .htpasswd folder is 8 folders deep, this is bad. Lol.

  2. #2
    Join Date
    Jul 2002
    Location
    Kuwait
    Posts
    10,573
    chmod 711 dir

    or just move the .htpasswd dir to something outside your web content dir
    Bashar Al-Abdulhadi - KuwaitNET Internet Services Serving customers since 1997
    Kuwait's First Webhosting and Domain Registration provider - an ICANN Accredited Registrar

    Twitter: Bashar Al-Abdulhadi

  3. #3
    Join Date
    Jun 2001
    Location
    South Carolina, USA
    Posts
    90
    I'm not sure you understood my problem.

    All the directories are chmod 777 (there isnt anything deserving more security than a .htpasswd in them).

    However, when I have a .htpasswd set up in a subdirectory (site.net/blah/cool) of a higher level directory (site.net/blah/), the subdirectory will not show up in the higher level directory's directory listing.

    Ill just link you to an example of my problem:
    http://cheesepie.net/sounds/ <--- folder of random stuff
    http://cheesepie.net/sounds/MP3s/ <-- folder of MP3s, htpasswd protected to save bandwidth

    If you notice, the MP3s folder does not show up in the sounds folder directory listing unless you are authorized to view the contents of the MP3 folder.
    Last edited by parsafliffum; 06-01-2004 at 05:44 PM.

  4. #4
    Join Date
    Jul 2002
    Location
    Kuwait
    Posts
    10,573
    so you want MP3s to show in the listing of /sounds/ ?
    Bashar Al-Abdulhadi - KuwaitNET Internet Services Serving customers since 1997
    Kuwait's First Webhosting and Domain Registration provider - an ICANN Accredited Registrar

    Twitter: Bashar Al-Abdulhadi

  5. #5
    Join Date
    Jun 2001
    Location
    South Carolina, USA
    Posts
    90
    Originally posted by Bashar
    so you want MP3s to show in the listing of /sounds/ ?
    Yes.

  6. #6
    Join Date
    Jul 2002
    Location
    Kuwait
    Posts
    10,573
    with default setup it works just fine i tested it and the protected directory shows in the directory listing

    it seems your setup has something wrong.
    Bashar Al-Abdulhadi - KuwaitNET Internet Services Serving customers since 1997
    Kuwait's First Webhosting and Domain Registration provider - an ICANN Accredited Registrar

    Twitter: Bashar Al-Abdulhadi

  7. #7
    Join Date
    Jun 2001
    Location
    South Carolina, USA
    Posts
    90
    Thats odd.

    There isnt much to the site cheesepie.net other than a headername and readmename in the .htaccess, lol.

  8. #8
    Join Date
    Jul 2002
    Location
    Kuwait
    Posts
    10,573
    try changing it and see if it works or not
    Bashar Al-Abdulhadi - KuwaitNET Internet Services Serving customers since 1997
    Kuwait's First Webhosting and Domain Registration provider - an ICANN Accredited Registrar

    Twitter: Bashar Al-Abdulhadi

  9. #9
    Join Date
    Jun 2001
    Location
    South Carolina, USA
    Posts
    90
    I've been messing around with settings for a few days now to no avail...

    Any ideas, anyone?

  10. #10
    Join Date
    Jul 2002
    Location
    Kuwait
    Posts
    10,573
    what does your .htaccess have?
    Bashar Al-Abdulhadi - KuwaitNET Internet Services Serving customers since 1997
    Kuwait's First Webhosting and Domain Registration provider - an ICANN Accredited Registrar

    Twitter: Bashar Al-Abdulhadi

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •