Results 1 to 7 of 7
  1. #1
    Join Date
    Mar 2004
    Posts
    295

    Opteron, Unable to run 64Bit Binaries

    I cannot get this dual opteron to run 64bit binaries, this is what happens with hlds.

    Auto detecting CPU
    Using AMD-Opteron (64 bit) Optimised binary.
    Auto-restarting the server on crash
    ./hlds_run: line 359: ./hlds_amd64: cannot execute binary file


    And ut2k4
    ./ucc-bin-linux-amd64: cannot execute binary file

    Yes, both files are their. And have access to them.

  2. #2
    Join Date
    Feb 2003
    Location
    Potsdam, NY
    Posts
    646
    almost looks like the kernel doesnt support 64 bit operation

  3. #3
    Join Date
    Mar 2004
    Posts
    295
    Linux ***hostname*** 2.4.25 #2 SMP Tue Apr 13 12:06:57 PDT 2004 i686 athlon i386 GNU/Linux

    This is what came /w it.

  4. #4
    Join Date
    Oct 2003
    Location
    Georgetown, Ontario
    Posts
    1,761
    consider upgrading to 2.4.26.

    2.4.25 has a few security holes.
    ии Repeat after me... ProSupport is the best... Prosupport is... ии
    ProSupport Host Support System - OUT NOW! Grab a copy yourself and see what the hype is about!
    VertiHost Inc. - We run a quality business. Do you?

  5. #5
    Join Date
    Feb 2003
    Location
    Potsdam, NY
    Posts
    646
    it isnt running with opteron support... you need to do a recompile. There should be an option where you select the CPU architecture type.

  6. #6
    Join Date
    Jun 2002
    Location
    United Kingdom
    Posts
    1,236
    thats compiled as a 32bit kernel by the looks of it

  7. #7
    Join Date
    Mar 2004
    Posts
    295
    K, contacted them about it, this was a angelnetworks install.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •