Results 1 to 4 of 4
  1. #1

    images reloading all the time

    ok ommg I know there are programmers, coders and hosters here so I might actually receive some help .. I'm building a php page and each time a link is visited for some reason all pages are reloaded all the time even though I'm reusing them .. for some reason they are not cached .. is there a solution to this? any piece of code that I might have to add? something need to be configured on the server?...

    I read on an earlier post here and someone suggested to put a mod_gzip_on no .. on a .httaccess and it worked for him .. but it wont work for me it gives me a 500 internal server error (I dont think my server even have mod_gzip install ) ..

    Please any help or pointers would be really appreaciated indeed ..


  2. #2
    Join Date
    May 2004
    World Wide Web
    You may try the following to see if mod_gzip is enabled/installed on your server:


    // Show all information, defaults to INFO_ALL

    // Show just the module information.
    // phpinfo(8) yields identical results.


    Real Value Hosting - Every day hosting solutions since 2003
    Shared Hosting Reseller Hosting VPS Dedicated Servers True 24 x 7 x 365 Support

  3. #3
    Join Date
    Mar 2003
    Kansas City, MO
    THere are many reasons why the page may be reloaded, I would start by setting an expires header in the document. Particularly, this does not bother me so much with html as it does images. Images are usually bigger than the HTML. (mine anyway...) So, I use a php program to setup the image download from the tag. <img src=myimage.php?id=file.jpg> . This works really well. You can control cache from there as well, I think.
    Promethyl Corporate.
    Webhosting and Development.

  4. #4
    Thanks Sonia, so its confrimed my site does not have mod_gzip on it ..

    Promethyl I do have expire headers I set them like this: <meta name="expires" content="never"> however on the server info test that Sonia told me to do I did notice under http response headers some setting like this: keepalive: timeout 15 ..
    will this be causing the problem ?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts