Results 1 to 5 of 5
  1. #1

    Weird problem with quotas

    For some reason quotas on my dedicated server do not seem to be refreshing. quota -u ajcrazy returns that he is using 380 megs of disk space, CPanel says hes using 380 megs of diskspace, but du -hs ajcrazy returns he is using 160 megs, as does the disk usage icon on CPanel.

    Also for some reason when I run the fixquotas script it says that quota support isn't enabled, yet i know darn well it is:

    server2# ./fixquotas
    !! No Filesystems are mounted with quota support !!

    Under freebsd you must edit /etc/fstab and turn on quotas.
    Note: make sure your kernel supports quotas before doing this.
    After you have remounted your file systems with quota support,
    re-run this script.

    fstab file:

    # Device Mountpoint FStype Options Dump Pass#
    /dev/ad0s1b none swap sw 0 0
    /dev/ad0s1a / ufs rw 1 1
    /dev/ad0s1h /home ufs rw,userquota,groupquota 2 2
    /dev/ad0s1e /tmp ufs rw 2 2
    /dev/ad0s1g /usr ufs rw 2 2
    /dev/ad0s1f /var ufs rw 2 2
    /dev/acd0c /cdrom cd9660 ro,noauto 0 0
    proc /proc procfs rw 0 0


    so... i dunno what the heck its talkin about quota support isnt enabled.

    Any ideas guys???

    Thanks!
    Last edited by EviL_SmUrF; 05-28-2004 at 02:26 AM.

  2. #2
    Join Date
    Jul 2002
    Location
    Kolding, Denmark
    Posts
    292
    Does "mount" show that quotas are enabled? Has the kernel been recompiled/updated recently?

    What does "find / -u ajcrazy" give you? Anything that might be outside the ajcrazy directory?
    Best regards,

    Anders C. Madsen
    Golden Planet Support - http://www.goldenplanet.com

  3. #3
    yeah the kernel has quotas enabled, cause i tested it before with the co-owner and it worked fine.

    the co-owner who is a lot more technically inclined then me and does all of the technical stuff for the box is gone till saturday, but, heres the return of the "mount" command:

    server2# mount
    /dev/ad0s1a on / (ufs, local)
    /dev/ad0s1h on /home (ufs, local, soft-updates)
    /dev/ad0s1e on /tmp (ufs, local, soft-updates)
    /dev/ad0s1g on /usr (ufs, local, soft-updates)
    /dev/ad0s1f on /var (ufs, local, soft-updates)
    procfs on /proc (procfs, local)
    server2#


    I'm not sure if that says that quotas are enabled or not.

    and find / -u ajcrazy doesnt work. says -u is an unknown option. (This is FreeBSD 4.9)

    If quotas werent enabled for /home, why would the box not let him upload anymore files and say he was over quota limit?
    Last edited by EviL_SmUrF; 05-28-2004 at 03:45 AM.

  4. #4
    Join Date
    Jul 2002
    Location
    Kolding, Denmark
    Posts
    292
    I don't know how FreeBSD mount shows it but this is how it looks on Linux:

    /dev/sdb2 on /home type ext3 (rw,noatime,usrquota,grpquota)

    - I suspect you should see something similar.

    Regarding the "find"-command: I wanted it to find all files belonging to user ajcrazy - perhaps "man mount" on your system can help you there.

    The quota-tools usually just reads two files in the root of the filesystem with quotas enabled. These files are not deleted when quotas are disabled but they are not updated either - and that might explain why the actual diskuse differs from the reported quota.

    Try this:

    mount -o remount /home

    - and see if that activates the quotas.
    Best regards,

    Anders C. Madsen
    Golden Planet Support - http://www.goldenplanet.com

  5. #5
    Join Date
    Mar 2003
    Location
    California USA
    Posts
    13,294
    dont forget, sql counts to diskspace
    Steven Ciaburri | Industry's Best Server Management - Rack911.com
    Software Auditing - 400+ Vulnerabilities Found - Quote @ https://www.RACK911Labs.com
    Fully Managed Dedicated Servers (Las Vegas, New York City, & Amsterdam) (AS62710)
    FreeBSD & Linux Server Management, Security Auditing, Server Optimization, PCI Compliance

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •