Results 1 to 6 of 6
  1. #1
    Join Date
    Aug 2001

    settings in http.conf

    i am getting around 30000 hits on my server/day and somehow i feel that many of my visitors arent able to view my site at all times.
    my stats have fallen.
    i have been told to check these settings in httpd.conf
    can you tell me what settings should i keep to accomodate max traffic on my server and at the same time keep my server stable/.

    # Timeout: The number of seconds before receives and sends time out.
    Timeout 180

    # KeepAlive: Whether or not to allow persistent connections (more than
    # one request per connection). Set to "Off" to deactivate.
    KeepAlive Off

    # MaxKeepAliveRequests: The maximum number of requests to allow
    # during a persistent connection. Set to 0 to allow an unlimited amount.
    # We recommend you leave this number high, for maximum performance.
    MaxKeepAliveRequests 100

    # KeepAliveTimeout: Number of seconds to wait for the next request from the
    # same client on the same connection.
    KeepAliveTimeout 15


  2. #2
    Join Date
    Dec 2003
    Brisbane, Queensland, Australia
    I was just wondering what are the specs for your server? Example Ram, CPU,

  3. #3
    Join Date
    Aug 2001
    its a dual 2.8 GHz xeon
    1GB ecc ram
    can you help?

  4. #4
    You may want to turn KeepAlives on as it saves a lot of TCP overhead by reusing connections. Also, check if your Apache is forking enough handlers to deal with the requests and set a limit on the maximum number of connections. The firewall may also be a bottleneck if you have conntrack on. You need to increase the connection tracking limit (if you are running Linux).
    ::. : Dedicated Servers : Virtual Machine Servers .::
    ::. Industry-Leading Remote Server Management .::
    ::. Automatic OS Re-image : Instant Server Reboot : Remote Serial Console .::
    ::. Over 20 OSes to choose from : Install a new OS every day .::

  5. #5
    Join Date
    Jan 2003
    Yes, but KeepAlive also ties up an apache until the client times out. Even at a few seconds, that can tie up a lot of apaches (and the associated memory) doing nothing productive.

    30,000 really isn't that much, unless it's a lot of large stuff. See what your MaxClients is set for. It shouldn't be above 1 per 2MB of RAM, but you should only need 150 or 200 with that traffic level.
    Game Servers are the next hot market!
    Slim margins, heavy support, fickle customers, and moronic suppliers!
    Start your own today!

  6. #6
    Join Date
    Feb 2003
    Might try tweaking these settings:

    MinSpareServers 5
    MaxSpareServers 10
    MaxClients 150

    Also you should look at a stats package to see if your Too Many Connections error is shown or create a custom error page for it which logs the accesses. If you find that this page is being hit lots then up the max clients.
    Off Topic Web Forum - A forum for talking about anything!!
    N.Z. Webmaster Community - Are you from New Zealand? Well signup to our forum!!!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts