Results 1 to 7 of 7
  1. #1

    Advanced Policy Firewall - Help

    Installed the advanced policy firewall via hostinglife.com, however when the service is started I seem to be getting this error:

    Warning: Unknown(): open_basedir restriction in effect. File(/home/h505763/public_html/index.php) is not within the allowed path(s): (/home/h617789:/usr/lib/php:/usr/local/lib/php:/tmp) in Unknown on line 0

    Warning: Unknown(/home/h505763/public_html/index.php): failed to open stream: Operation not permitted in Unknown on line 0

    Warning: (null)(): Failed opening '/home/h505763/public_html/index.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in Unknown on line 0

    when I try to view the pages by typing Http://xx.xx.xx.xx/~account

    Example:
    http://66.45.239.146/~h505763/

    Also, sometimes when trying to view my accounts on the new server via that method, with the APF service stopped, it works and shows the accounts, however rather than showing the IP in the address bar it uses one of my customers URL's and then the /~username. Why that customer, and how do I get it to show my url instead??

    Example:

    http://66.45.239.146/~h505763

    Thanks!!

  2. #2
    Join Date
    May 2004
    Posts
    394
    APF has nothing to do with PHP and Apache, APF only uses iptables to set rules on TCP/IP, thats all, APF blocks everything on TCP and UDP except those you added in APF configuration file..

    You might have missed with the Apache configuration file, otherwise APF wont effect any configuration files on your system.


    You better take alook again at your apache configuration file.

    Do you use WHM/Cpanel? Cpanel is a little buggy with those things..

    Please let us know more information about your case, hope we can help you to solve this..

  3. #3
    Join Date
    Jun 2003
    Location
    UK
    Posts
    6,601
    As this is WHM probably can do WHM, Security Settings. Openbase_dir setting and override it

    Rus
    Russ Foster - Industry Curmudgeon

  4. #4
    I noticed after posting and playing a bit that the 2 are unrelated. The problem seems to exist no matter wether or not the APF is started or stopped.

    Any other suggestions on what could be cauing this and / or how ot fix it? I am new to dedicated derver hosting.

    Thanks!

  5. #5
    Join Date
    Nov 2002
    Location
    Central Florida, USA
    Posts
    382
    Did you see the post above your last one about disabling the open_basedir option in Tweak Security in WHM? This may not be something you want to do, but is likely what has enabled open_base dir protection.

    Good Luck
    Rob
    Founder and former owner of SRLnet. Sold in 2006

  6. #6
    Join Date
    May 2004
    Posts
    394
    It shows the customers domain instade of your domain , this is because of the WHM configurations set, anyway, if you don't want your customer account to be shown, edit your apache configration file, and make the first virtual host is your own domain virtual host instead of your customers.

  7. #7
    Thanks everyone, seems to be working good now... Once again, this forum has helped me fix something up

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •