hosted by liquidweb


Go Back   Web Hosting Talk : Web Hosting Main Forums : Hosting Security and Technology : Qmail smtp slow
Reply

Forum Jump

Qmail smtp slow

Reply Post New Thread In Hosting Security and Technology Subscription
 
Send news tip View All Posts Thread Tools Search this Thread Display Modes
  #1  
Old 05-18-2004, 07:08 PM
jezza jezza is offline
New Member
 
Join Date: May 2004
Posts: 3

Qmail smtp slow


Hi,

Apologies if this has been covered before, but my qmail smtp server is acting very slow. If I telnet to port 25 on localhost it's quick, but if I do the same from a remote machine It takes ages to respond. I'm guessing it's a DNS problem, but the server's name resolves OK, as does the machine I'm coming in from. Does anybody have any ideas? Your help would be very much appreciated.

Thanks
Jez



Sponsored Links
  #2  
Old 05-18-2004, 07:30 PM
stftk stftk is offline
Web Hosting Evangelist
 
Join Date: May 2003
Posts: 472
If you want to post or PM the domain I can run some DNS checks on it.

  #3  
Old 05-18-2004, 09:05 PM
pmabraham pmabraham is offline
Web Hosting Master
 
Join Date: Dec 2001
Posts: 5,221
Greetings:

Run a http://www.dnsreport.com/ on the domain name.

The main A record and www record (a or cname) may be ok; the mx may have problems.

Other things to check:

/etc/resolv.conf on the mail server -- are the entries correct?

Are you using the paranoid switch for tcpservers for the qmail start up? That can delay the connection to port 25 from the outside.

Thank you.

__________________
---
Peter M. Abraham
LinkedIn Profile


Sponsored Links
  #4  
Old 05-19-2004, 03:52 PM
jezza jezza is offline
New Member
 
Join Date: May 2004
Posts: 3
Thanks all,

I checked with dnsreport.com, and found some problems with my nameservers, but I still have the slow smtp problem.
I'm using xinetd to start qmail.

Jezza

  #5  
Old 05-19-2004, 04:00 PM
jezza jezza is offline
New Member
 
Join Date: May 2004
Posts: 3
Ah,

It turns out that my ISP Freeserve (now wanadoo) forces all port 25 traffic via their own web servers!

Thanks for your help guys.

Jez

  #6  
Old 05-19-2004, 04:04 PM
davila davila is offline
Junior Guru Wannabe
 
Join Date: Mar 2004
Posts: 66
try to disable reverse lookups by editing /etc/xinetd.d/smtp and add -Rt0 after server_Args like this :

server_args = -Rt0

  #7  
Old 06-20-2004, 08:19 PM
blockcipher blockcipher is offline
Web Hosting Master
 
Join Date: Oct 2003
Location: California
Posts: 1,271
I have checked all of the above and still have this problem. POP3 is quick, but sending out mail takes forever. Any ideas?

__________________
http://www.wavesoftech.com

  #8  
Old 06-21-2004, 04:53 PM
dan_erat dan_erat is offline
Web Hosting Master
 
Join Date: Jun 2003
Posts: 673
Make sure that you're not checking any broken DNSbls from rblsmtpd, if you're using it.

  #9  
Old 06-21-2004, 05:32 PM
blockcipher blockcipher is offline
Web Hosting Master
 
Join Date: Oct 2003
Location: California
Posts: 1,271
I don't think I'm using anything like that. Its a Plesk 7.0.3 system and I think it came with the basics. Is there a file I need to look at that will tell me this?

Sorry for the dumb questions I have no experience with qmail

__________________
http://www.wavesoftech.com

  #10  
Old 06-21-2004, 05:33 PM
BigGorilla BigGorilla is offline
Aspiring Evangelist
 
Join Date: Mar 2004
Location: Chicago, IL
Posts: 384
Couple suggestions (some already mentioned)....

1) Make sure the machine is resolving hosts properly. Consider using a caching DNS server locally on the machine to speed up queries (such as djbdns). Make sure to put 127.0.0.1 as the first line of your /etc/resolv.conf if you install a local caching DNS.

2) Check your rbl setups as mentioned.

3) How big is your mail queue (run qmail-qstat as root from a shell prompt)? Qmail can run slower if the mail queue is large (but usually not unless the queue size is 10's of thousands or 100's of thousands in size).

Also, it's generally recommended qmail runs behind ucspi-tcp and not xinetd for better performance, but I am not familiar with Plesk's setup.


Last edited by BigGorilla; 06-21-2004 at 05:38 PM.
  #11  
Old 06-21-2004, 05:37 PM
blockcipher blockcipher is offline
Web Hosting Master
 
Join Date: Oct 2003
Location: California
Posts: 1,271
The queue size is extremely small as of now. This dedicated box only has one site on it. Not alot of mails go through it. As for my resolv.conf file. Everytime I edit it, it changed. Probably plesk doing that.

__________________
http://www.wavesoftech.com

  #12  
Old 06-21-2004, 05:38 PM
dan_erat dan_erat is offline
Web Hosting Master
 
Join Date: Jun 2003
Posts: 673
Please paste the output of "cat /etc/xinetd.d/smtp" (if that's where qmail-smtpd is being started).

  #13  
Old 06-21-2004, 05:42 PM
blockcipher blockcipher is offline
Web Hosting Master
 
Join Date: Oct 2003
Location: California
Posts: 1,271
Quote:
[root@u15149596 etc]# cat /etc/xinetd.d/smtp
cat: /etc/xinetd.d/smtp: No such file or directory
[root@u15149596 etc]#
I also found this, this the one you talking about?

Quote:
[root@u15149596 xinetd.d]# cat /etc/xinetd.d/smtp_psa

service smtp
{
socket_type = stream
protocol = tcp
wait = no
disable = no
user = root
instances = UNLIMITED
server = /var/qmail/bin/tcp-env
server_args = /var/qmail/bin/relaylock /var/qmail/bin/qmail-smtpd /var/qmail/bin/smtp_auth /var/qmail/bin/true /var/qmail/bin/cmd5checkpw /var/qmail/bin/true
}
[root@u15149596 xinetd.d]#

__________________
http://www.wavesoftech.com

  #14  
Old 06-21-2004, 05:50 PM
blockcipher blockcipher is offline
Web Hosting Master
 
Join Date: Oct 2003
Location: California
Posts: 1,271
When changing it to:

server_args = -Rt0 and then service xinetd restart

Mail won't even send. So that doesn't seem to work on my box.

Just an update

__________________
http://www.wavesoftech.com

  #15  
Old 06-21-2004, 05:52 PM
blockcipher blockcipher is offline
Web Hosting Master
 
Join Date: Oct 2003
Location: California
Posts: 1,271
Oh goodness. This was my fault I put that in the lines on its own, sorry! I put -Rt0 before the other commands and that seems to work. Sorry to have put you out of your way guys. I really do appreciate the help. I'm all fixed up!

__________________
http://www.wavesoftech.com

Reply

Related posts from TheWhir.com
Title Type Date Posted
As STARTTLS Adoption Grows, Facebook Reports Huge Jump in Encrypted Notification Emails Web Hosting News 2014-08-20 14:01:32
Hosting Ecosystem Members Seek Net Neutrality Regulations from FCC, Even If It Means Causing Mischief Blog 2014-05-13 13:18:56
FCC Changing Broadband Rules Language to Reflect Concern Over Internet “Slow Lane” Web Hosting News 2014-05-12 16:05:36
SAP Investing and Aiming for $4.75 Billion Cloud Revenue in 2017 Web Hosting News 2014-01-23 09:42:02
Security Experts Refute German Email Security Firms Secure Data Storage Claim Web Hosting News 2013-08-13 16:24:48


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes
Postbit Selector

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump
Login:
Log in with your username and password
Username:
Password:



Forgot Password?
Advertisement:
Web Hosting News:



 

X

Welcome to WebHostingTalk.com

Create your username to jump into the discussion!

WebHostingTalk.com is the largest, most influentual web hosting community on the Internet. Join us by filling in the form below.


(4 digit year)

Already a member?