Results 1 to 13 of 13
  1. #1

    Big problem with big company , Enom dont support

    I have bought windows hosting from enom for access with asp use, out site working on local computer normally, but when we upload database and site to server its not working, i feel that there is connection problem with database.

    I asked this to enom via ticket and asking continous from the last one week, but they dont seems to support, just asked me i am not their direct reseller, and asked to contact nirmani for help, but nirmani dont sell windows hosting, they only buy domain for enom, enom dont try to realize this problem.

    Please advice me what should i do.


  2. #2
    Join Date
    Jan 2004
    What kind of error are you getting? Do you know if it is using a DSN?

  3. #3
    explorer wrote server error.

    I asked about dsn to enom because also mentioned me this, but they did not wrote any thing about it, I dont know about it exactly.

  4. #4
    Join Date
    Jan 2004
    One of the most common problems when publishing an Access database is improper permissions on the server. If you could give me the exact error I may be able to rule this out.

  5. #5
    Can you check this url i made for test , also enom gave to use connection string like below, please let me know if you have any solution.

    //Dim objDbConn
    //Set objDbConn = Server.CreateObject("ADODB.Connection")
    //objDbConn.Open "DRIVER={Microsoft Access Driver (*.mdb)}; DBQ=" & Server.MapPath("\db\shopdb.mdb")

  6. #6
    Join Date
    Jan 2004
    I recently started getting that error after installing an unrelated component. However calling the jet driver directly might work. Try this...
    Dim g_strRootPath
    Dim strdbPath
    Dim strConnectionString
    Dim g_objCN
    'Web site physical path
    g_strRootPath = Server.MapPath(Request.ServerVariables("Script_Name"))
    g_strRootPath = Left(g_strRootPath, Len(g_strRootPath) - Len(Request.ServerVariables("Script_Name")))
    'Microsoft access database physical path
    strdbPath = g_strRootPath & "\db\shopdb.mdb"
    'Microsoft access database connection
    strConnectionString = "PROVIDER=Microsoft.Jet.OLEDB.4.0;" & _
    	"Data Source=" & strdbPath & ";"
    Set g_objCN = CreateObject("ADODB.Connection")
    g_objCN.Open strConnectionString
    I know there is a lot of variables but it lends itself well for the project I used it on.
    Hope it helps .

  7. #7
    I just copy and past you code in connection.asp file, but still that error coming to me, can you check it at

    shop folder contain all files of this test , and db folder contain database

  8. #8
    Join Date
    Jul 2003
    Had a similar problem with a client using enom's asp hosting.

    Make sure your db folder has write access enabled.
    In order to understand recursion, one must first understand recursion.
    If you feel like it, you can read my blog
    Signal > Noise

  9. #9
    db folder set to 554 , i tried to change to any other values many tiems, but when i check again its saying 554 again.

    Plz advice.

  10. #10
    Join Date
    Jan 2004
    I don't know what you mean by 554 but the error that I see now tells me that the path to the database is wrong. Instead of 'E:\userdirs\wwwroot\db\shopdb.mdb' it should be something like 'E:\userdirs\wwwroot\[your site's folder]\db\shopdb.mdb'. I suggest you find out the actual path and hard code it.

    To find the path try the following....
    Response.Write Server.MapPath("authenticate.asp")
    Also note that the db folder is not secure so I would think that the host has not set the proper permissions for the database.

  11. #11
    554 is permission which you can set via ftp software of any folder with right click, its not getting change to any other value from 554.

    Also I have used your code in connection file, and there is not mentioned E drive path , how did you see this E drive path ?
    I am getting error "Internal Server Error " HTTP 500.

    Does enom support to their clients on these type of issues ?

    I am seriously thinking to switch from enom after their nice support.

  12. #12
    Join Date
    Jan 2004
    You probably do not see the error message because you are using Internet Explorer with friendly errors turned on.

    To disable go to Tools/Internet Options.
    Click on the Advanced tab.
    In the Browsing area look for uncheck "Show friendly HTTP error messages", uncheck "Show friendly URLs" and check "Display a notification about every script error".

    Hope this helps!

  13. #13
    Join Date
    Jan 2004
    By the way, I doubt that their FTP server allows the user to change permissions. You will have to contact them for that.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts