Results 1 to 8 of 8
  1. #1
    Join Date
    Sep 2000
    Location
    San Diego's North County
    Posts
    21

    Question

    I have been unable to delete some _vti_ directories that [I think} FrontPage installed (_vti_cnf, _vti_pvt, etc.), either using FTP or using Telnet. I can't see any files in the dir, yet Telnet and FTP are both telling me that the directories aren't empty. I've tried rmdir and the directory name, but it won't go. Same thing with FTP. HOW can I get rid of these directories? (I think it may be part of why my Plesk-enabled password-protected directories won't accept any of the login/password combinations I created earlier... I thought I might have an old .htaccess file in there that was conflicting, but I can't see anything via FTP or telnet...

    Wm

    William Morton
    Second Glance

  2. #2

    Talking

    Ahh, the wonderful world of FrontPage.

    Often FP sets up directories with the wrong user permissions. You probably will not be able to delete those directories untill you either delete them as root user or change the ownership of them to you.
    Benjamin S.
    VeoWeb Premium Hosting
    http://www.VeoWeb.net

  3. #3
    Join Date
    Sep 2000
    Location
    San Diego's North County
    Posts
    21

    Unhappy

    I actually did a chown to the FTP login name, and when I tried to delete them via FTP I was loggin in under that user/pass. I then tried to telnet in to the root acct and rmdir, but had the same problem. If I can change the attributes via FTP, would setting them to 777 (or anything else) allow me to delete them?

    Wm
    William Morton
    Second Glance

  4. #4
    Try an "rm -rf _vti*" in that directory.

    Be careful with rm -rf though... it doesn't know or care if you make a mistake. The files are simply gone.

    Matt
    mlightner@site5.com
    Matt Lightner - http://www.mattlightner.com/
    - First initial to the last name at the mail service provided by the world's largest search engine
    - Founder and CEO (Former) Site5.com, sold in 2008
    - Really honestly wants to be a good WHT citizen but can never remember all the correct etiquette. Mods, sorry in advance

  5. #5
    I agree with Matt.
    A rm -r directory_name could do the trick for you.

    Give that a shot and see what happens.
    Benjamin S.
    VeoWeb Premium Hosting
    http://www.VeoWeb.net

  6. #6
    Consider the following...
    Usually, FPX sets the owernas 'nobody' on its directories, I have no clues why, (well I know why... it was too secure, so they had to share all the same owner to make sure it is exploitable) anyway, you might have to su to root to remove these files if you try to do it from 'admin' or the owner of the account. Also, as pointed before, a rm -R dirname will do the trick once you are as root.
    Félix C.Courtemanche · webmaster@can-host.com
    Can-Host Networks · http://www.can-host.com
    web«cp Control Panel · http://webcp.can-host.com

  7. #7
    Try removing FP Extensions first then delete files and redo FP Extensions
    Bob

  8. #8
    Join Date
    Sep 2000
    Location
    San Diego's North County
    Posts
    21

    rm -rf _vti*

    This did the trick! THANX all!
    Now I've just gotta figure out why my password-protected directory is still not allowing me in... :-/

    Wm

    William Morton
    Second Glance

  9. Newsletters

    Subscribe Now & Get The WHT Quick Start Guide!

Related Posts from theWHIR.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •