Results 1 to 16 of 16
  1. #1

    New Plesk Server & RPM Dependency issues

    Just got a new server at ServerMatrix. I'm pretty happy with it, except I'm having some dependency issues. Maybe I can get some help here:

    Code:
    cyndane tmp # up2date -u
    Name                                    Version        Rel
    ----------------------------------------------------------
    spamassassin                            2.55           3.1                 i386
     
     
    Testing package set / solving RPM inter-dependencies...
    There was a package dependency problem. The message was:
     
    Unresolvable chain of dependencies:
    psa-spamassassin-7.0.2-rhel3.build040408 requires spamassassin >= 2.60
    spamassassin-tools-2.61-2                requires perl-Mail-SpamAssassin = 2.61-2
    Code:
    cyndane mail # rpm -qa | grep -i spam
    spamassassin-tools-2.61-2
    spamassassin-2.61-2
    psa-spamassassin-7.0.2-rhel3.build040408.00
    perl-Mail-SpamAssassin-2.61-2

  2. #2
    Join Date
    Jul 2001
    Location
    /dev/null
    Posts
    1,219
    You need to disable spamassassin in your up2date.conf because Plesk comes with it's own spamassassin distribution.

  3. #3
    Join Date
    Dec 2004
    Posts
    67
    Bump, getting the same error on my new Plesk server, RHEL 3.

    Which spamassassin do I need to tell it to skip, and where? The only up2date.conf files I'm finding are to config the logs... and when I tried adding spamassassin to the SkipPkgs line in "/etc/sysconfig/rhn/up2date" nothing changed.

    Thanks in advance.

  4. #4
    Join Date
    Mar 2003
    Location
    California USA
    Posts
    13,294
    up2date --config

    the pkgskiplist is number 9

    add

    spamassassin*;

    to the end of it.
    Steven Ciaburri | Industry's Best Server Management - Rack911.com
    Software Auditing - 400+ Vulnerabilities Found - Quote @ https://www.RACK911Labs.com
    Fully Managed Dedicated Servers (Las Vegas, New York City, & Amsterdam) (AS62710)
    FreeBSD & Linux Server Management, Security Auditing, Server Optimization, PCI Compliance

  5. #5
    Join Date
    Dec 2004
    Posts
    67
    Thanks.

  6. #6
    Join Date
    Dec 2004
    Location
    Romania
    Posts
    32
    Also you can use YUM updates and from AtomicTurtle to instll SpamAssasin, this will resolve dependencies as well.

  7. #7
    Join Date
    Dec 2004
    Posts
    67
    Trying to install something new (HTOP) now I get this...

    (after I used thelinuxguy's fix, and did an update with up2date, I had to run rpm --rebuild because Plesk was freaking out about connecting to the RPM database, Plesk works fine now, but...)

    # rpm -Uvh htop-0.5-1.1.el3.rf.i386.rpm
    rpmdb: Program version 4.2 doesn't match environment version
    error: db4 error(22) from dbenv->open: Invalid argument
    error: cannot open Packages index using db3 - Invalid argument (22)
    error: cannot open Packages database in /var/lib/rpm
    warning: htop-0.5-1.1.el3.rf.i386.rpm: V3 DSA signature: NOKEY, key ID 6b8d79e6
    rpmdb: Program version 4.2 doesn't match environment version
    error: db4 error(22) from dbenv->open: Invalid argument
    error: cannot open Packages database in /var/lib/rpm
    rpmdb: Program version 4.2 doesn't match environment version
    error: db4 error(22) from dbenv->open: Invalid argument
    error: cannot open Packages database in /var/lib/rpm

  8. #8
    Join Date
    Mar 2003
    Location
    California USA
    Posts
    13,294
    What kernel are you using? What happens when you run

    LD_ASSUME_KERNEL=2.2.5 rpm -Uvh htop-0.5-1.1.el3.rf.i386.rpm
    Steven Ciaburri | Industry's Best Server Management - Rack911.com
    Software Auditing - 400+ Vulnerabilities Found - Quote @ https://www.RACK911Labs.com
    Fully Managed Dedicated Servers (Las Vegas, New York City, & Amsterdam) (AS62710)
    FreeBSD & Linux Server Management, Security Auditing, Server Optimization, PCI Compliance

  9. #9
    Join Date
    Dec 2004
    Posts
    67
    Originally posted by thelinuxguy
    What kernel are you using? What happens when you run

    LD_ASSUME_KERNEL=2.2.5 rpm -Uvh htop-0.5-1.1.el3.rf.i386.rpm
    That made it work as it should have, KEY warning, then successful install.

    I have to use that LD_ASSUME_KERNEL to do anything with RPM,

    LD_ASSUME_KERNEL=2.2.5 rpm -qa | grep kernel
    kernel-pcmcia-cs-3.1.31-13
    kernel-2.4.21-27.0.1.EL
    kernel-2.4.21-4.EL
    kernel-source-2.4.21-27.0.1.EL
    kernel-utils-2.4-8.37.7

  10. #10
    Join Date
    Mar 2003
    Location
    California USA
    Posts
    13,294
    cat /etc/redhat-release

    then

    uname -r

    whats the output?
    Steven Ciaburri | Industry's Best Server Management - Rack911.com
    Software Auditing - 400+ Vulnerabilities Found - Quote @ https://www.RACK911Labs.com
    Fully Managed Dedicated Servers (Las Vegas, New York City, & Amsterdam) (AS62710)
    FreeBSD & Linux Server Management, Security Auditing, Server Optimization, PCI Compliance

  11. #11
    Join Date
    Dec 2004
    Posts
    67
    Red Hat Enterprise Linux ES release 3 (Taroon Update 4)
    2.4.21-27.0.1.EL

  12. #12
    Join Date
    Mar 2003
    Location
    California USA
    Posts
    13,294
    Hrmm

    LD_ASSUME_KERNEL=2.2.5 rpm -qa | grep rpm

    and paste the result.
    Steven Ciaburri | Industry's Best Server Management - Rack911.com
    Software Auditing - 400+ Vulnerabilities Found - Quote @ https://www.RACK911Labs.com
    Fully Managed Dedicated Servers (Las Vegas, New York City, & Amsterdam) (AS62710)
    FreeBSD & Linux Server Management, Security Auditing, Server Optimization, PCI Compliance

  13. #13
    Join Date
    Dec 2004
    Posts
    67
    LD_ASSUME_KERNEL=2.2.5 rpm -qa | grep rpm

    redhat-java-rpm-scripts-1.0.2-2
    rpm-build-4.2.3-13
    rpm-devel-4.2.3-13
    rpmdb-redhat-3-0.20041216
    rpm-python-4.2.3-13
    rpm-4.2.3-13
    redhat-rpm-config-8.0.28-2
    rpm-libs-4.2.3-13

  14. #14
    Join Date
    Mar 2003
    Location
    California USA
    Posts
    13,294
    rm -f /var/lib/rpm/__db*
    rpm -v -v --rebuilddb
    Steven Ciaburri | Industry's Best Server Management - Rack911.com
    Software Auditing - 400+ Vulnerabilities Found - Quote @ https://www.RACK911Labs.com
    Fully Managed Dedicated Servers (Las Vegas, New York City, & Amsterdam) (AS62710)
    FreeBSD & Linux Server Management, Security Auditing, Server Optimization, PCI Compliance

  15. #15
    Join Date
    Dec 2004
    Posts
    67
    (from /var/lib/rpm/)
    # rm -f __db.00*
    # rpm --rebuilddb
    # rpm -qa
    rpmdb: Program version 4.2 doesn't match environment version
    error: db4 error(22) from dbenv->open: Invalid argument
    error: cannot open Packages index using db3 - Invalid argument (22)
    error: cannot open Packages database in /var/lib/rpm
    no packages

  16. #16
    Join Date
    Mar 2003
    Location
    California USA
    Posts
    13,294
    Have a read in this thread:

    http://forum.sw-soft.com/showthread....0880#post90880

    Apparently its a plesk/rhe issue they both need to fix
    Steven Ciaburri | Industry's Best Server Management - Rack911.com
    Software Auditing - 400+ Vulnerabilities Found - Quote @ https://www.RACK911Labs.com
    Fully Managed Dedicated Servers (Las Vegas, New York City, & Amsterdam) (AS62710)
    FreeBSD & Linux Server Management, Security Auditing, Server Optimization, PCI Compliance

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •