Results 1 to 7 of 7
  1. #1
    Join Date
    Feb 2003
    Location
    Singapore
    Posts
    240

    any plesk host panel experts ard? i need help with this open_basedir restriction...

    i give up....

    what should i type in my vhost.conf for the following open_basedir error?

    http://gallery.keeptouch.net

    my script for that line of error is :

    $vbpath ="/usr/local/psa/home/vhosts/keeptouch.net/subdomains/forums/httpdocs"; // changeme
    $pppath ="/usr/local/psa/home/vhosts/keeptouch.net/subdomains/gallery/httpdocs"; // changeme
    chdir($vbpath);
    require("./global.php");

    can any experts help me??

  2. #2
    Join Date
    Dec 2001
    Location
    Above The Clouds
    Posts
    6,999
    Damn, who installed Plesk for you? Because that is a mess. If I was you, I'd going for a complete reinstall as the path should be:

    /home/httpd/vhosts/domain.com

    I would turn off open_basedir for that domain with these directives:
    Code:
    <Directory /usr/local/psa/home/vhosts/keeptouch.net>
    php_admin_value open_basedir none
    </Directory>
    And then run:

    /usr/local/psa/admin/sbin/websrvmng -u --vhost-name=keeptouch.net

    But seriously, that isn't the correct install for Plesk.
    Laurence Flynn @ atOmicVPS LTD
    Linux & Windows Cloud Hosting Solutions Powered by OnApp
    Fully Managed [Shared][Reseller][Cloud VPS] [Dedicated]
    Featuring the atOmicSTACK ● Speed ● Performance ● Reliability

  3. #3
    Join Date
    Feb 2003
    Location
    Singapore
    Posts
    240
    Originally posted by NexDog
    Damn, who installed Plesk for you? Because that is a mess. If I was you, I'd going for a complete reinstall as the path should be:

    /home/httpd/vhosts/domain.com

    I would turn off open_basedir for that domain with these directives:
    Code:
    <Directory /usr/local/psa/home/vhosts/keeptouch.net>
    php_admin_value open_basedir none
    </Directory>
    And then run:

    /usr/local/psa/admin/sbin/websrvmng -u --vhost-name=keeptouch.net

    But seriously, that isn't the correct install for Plesk.
    its correctly installed

    cos i am using freeBSD 4.9 thats why the path is slightly different from yours... (i did not change the default installation path)

  4. #4
    Join Date
    Dec 2001
    Location
    Above The Clouds
    Posts
    6,999
    I wasn't aware the path was different on FreeBSD. Anyhow, did you try the fix?
    Laurence Flynn @ atOmicVPS LTD
    Linux & Windows Cloud Hosting Solutions Powered by OnApp
    Fully Managed [Shared][Reseller][Cloud VPS] [Dedicated]
    Featuring the atOmicSTACK ● Speed ● Performance ● Reliability

  5. #5
    Join Date
    Feb 2003
    Location
    Singapore
    Posts
    240
    Originally posted by NexDog
    I wasn't aware the path was different on FreeBSD. Anyhow, did you try the fix?
    strangely enough it still dun works...

  6. #6
    Join Date
    Dec 2001
    Location
    Above The Clouds
    Posts
    6,999
    Try this then:
    Code:
    <Directory /usr/local/psa/home/vhosts/keeptouch.net/httpdocs>
    php_admin_value open_basedir none
    </Directory>
    Reload the conf via websrvmng and also restart apache.
    Laurence Flynn @ atOmicVPS LTD
    Linux & Windows Cloud Hosting Solutions Powered by OnApp
    Fully Managed [Shared][Reseller][Cloud VPS] [Dedicated]
    Featuring the atOmicSTACK ● Speed ● Performance ● Reliability

  7. #7
    Join Date
    Feb 2003
    Location
    Singapore
    Posts
    240
    Originally posted by NexDog
    Try this then:
    Code:
    <Directory /usr/local/psa/home/vhosts/keeptouch.net/httpdocs>
    php_admin_value open_basedir none
    </Directory>
    Reload the conf via websrvmng and also restart apache.
    its ok now... i requested for plesk support to fix it for me...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •