Results 1 to 3 of 3
  1. #1
    Join Date
    Jan 2003

    Red hat enterprise and mod_layout

    Hello guys, i have posted this problem also on another forum hope someone can help me:

    Hi all guys, hope someone can help me.
    I need to install mode_layout no my red_hat enterprise, but when i go to make for the installation of mod_layout-4.0.1a i got this errors:
    # make
    Makefile:7: /usr/local/apache2/build/ No such file or directory
    make: *** No rule to make target `/usr/local/apache2/build/'. Stop.
    I think that is due the fact the mod_layout looks for the standard installation of apache, and anyway i can't find this file in the system. So i have tried with an rpm, but i got this error:
    rpm -ivh apache2-mod_layout-2.0.48_4.0.1a-2sls.i586.rpm
    warning: apache2-mod_layout-2.0.48_4.0.1a-2sls.i586.rpm: V3 DSA signature: NOKEY, key ID 67f22696
    error: Failed dependencies:
    rpm-helper is needed by apache2-mod_layout-2.0.48_4.0.1a-2sls
    apache2 = 2.0.48 is needed by apache2-mod_layout-2.0.48_4.0.1a-2sls
    apache2-conf is needed by apache2-mod_layout-2.0.48_4.0.1a-2sls
    Tried with up2date on rhn but seems that the package is not present. Wath i should do? I don't want uninstall apache and all dependied modules and then reinstall apache from sources. Does anyone have a solution? my httpd -v says:
    Server version: Apache/2.0.46
    Hope someon can help me

    Many thanks in advance.

  2. #2
    Join Date
    Jul 2003
    Nothing but, net
    If you're running 2.0.46 and it required 2.0.48, just upgrade?

  3. #3
    Join Date
    Jan 2003
    This is why i hate rpm based distribution. In practice i can't upgrade due to a lot of dependencies:
    error: Failed dependencies:
    httpd-mmn = 20020903 is needed by (installed) mod_perl-1.99_09-10.ent
    httpd-mmn = 20020903 is needed by (installed) mod_python-3.0.3-2.ent
    httpd-mmn = 20020903 is needed by (installed) mod_ssl-2.0.46-25.ent
    httpd-mmn = 20020903 is needed by (installed) php-4.3.2-8.ent
    httpd-mmn = 20020903 is needed by (installed) mod_authz_ldap-0.22-3
    webserver is needed by (installed) webalizer-2.01_10-15.ent
    httpd >= 2.0.40 is needed by (installed) mod_perl-1.99_09-10.ent
    httpd >= 2.0.40 is needed by (installed) mod_python-3.0.3-2.ent
    httpd = 2.0.46-25.ent is needed by (installed) mod_ssl-2.0.46-25.ent
    httpd is needed by (installed) redhat-config-httpd-1.1.0-4
    httpd is needed by (installed) squirrelmail-1.2.11-1
    Seems that the only solution is remove all the package an reinstall from source from the scratch, dammit.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts