Results 1 to 2 of 2

Thread: Upgrading PHP

  1. #1

    Upgrading PHP

    Im currenting running version 4.3.3

    I have got the source for 4.3.5
    and ive compiled it with these options

    ./configure --with-mysql --with-gd --with-zlib-dir=/usr/include --with-apache=../apache_1.3.28

    i have then, run make and make install, then gone to the apache directory and compiled that, also activating the php module in the configure.
    ( have copied php.ini to /usr/local/lib )

    ( Restarted apache )
    For some reason, once ive gone through this process, it doesnt seem to upgrade my php software.

    phpinfo still says its running the old version of php.

    Is there something i need to do to get rid of the old version ?


  2. #2
    Join Date
    Feb 2004
    Hi switched,

    Try to run the configure command of your old php version with your additional options(This you can get from phpinfo.php file). Then make & make install, Restart Apache. Now check both in prompt (php -v) and phpinfo.php file.

    Hope this may help you to resolve the problem.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts