Results 1 to 3 of 3
  1. #1

    Question killed my server.....

    Um, I accidently stuffed my own site.

    I was trying to set up PEAR in a "no command line" "no access to php.ini" shared hosting environment.

    I was running this line of php on my localhost....

    ini_set("include_path", "C:/php/www/html/pear/");

    I then ftp'd everything to the server changing the above line (carelessly) to this....

    ini_set("include_path", "/var/www/html/pear/");

    All of a sudden everything was 403 forbidden. The Error log spat out a "unable to check htaccess file, ensure it is readable".

    Current sitation.... I chmodded everything to 777 and now I can get .html files.

    Then if I point my browser to a .php file, I get an "Internal Server Error" page, if I place php code in a .html page it isn't parsed.

    If I chmod everything back to 776, for example, I'm back in "Forbidden" land, although the "403" is only seen in the taskbar of internet explorer.

    I have e-mailed/warned the hosting provider, but i'm not holding my breath waiting for them to try and repair something I basically broke myself. (barring a huge coincidence)

    Question, is it normal to be able to access (and edit) the php.ini file via FTP on a shared host?
    Last edited by skalie; 04-14-2004 at 06:07 AM.

  2. #2
    Join Date
    Dec 2001
    Above The Clouds
    On a plesk system we have to give access to pear on a case-by-case basis. It isn't php.ini that you are manipulating but apache directives. We write the rules in a container in a vhost.conf that is placed in a domain's conf directoty.
    <Directory /home/httpd/vhosts/>
    php_admin_value open_basedir "/usr/share/pear:/home/httpd/vhosts/"
    Laurence Flynn @ atOmicVPS LTD
    Linux & Windows Cloud Hosting Solutions Powered by OnApp
    Fully Managed [Shared][Reseller][Cloud VPS] [Dedicated]
    Featuring the atOmicSTACK ● Speed ● Performance ● Reliability

  3. #3
    Managed to sort it, I had messed up my chmod settings....

    755 to all directories(rwxr-xr-x)
    644 to all files(rw-r--r--) needs to be

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts