Results 1 to 28 of 28
  1. #1
    Join Date
    Apr 2004
    Posts
    24

    Bind not listening ?!

    hey,

    ive recently got f0xy.net to point at my home server. i forwarded port 53 to the sevrer, aswell as all other web releated ports. ( both tcp & udp ). i created two nameservers -> ns1.f0xy.net and ns2.f0xy.net , and pointed them to my ip address ( 82.33.155.48 ). Its been about 5 days now so it should have gotten round everyones ISP, but the domain still does not work. ive created an entry in the named.conf and created a zone file. You can access the server through 82.33.155.48, and you will see the default home page.

    but i cant get to my server through the domain.... whenever i do a test on dsl reports it says it cant connect to the dns through port 53....and when you try and connect to the server through telnet on port 53 you just get connection refused....

    any ideas what might be happening?

    thanks

  2. #2
    Why would you have 2 "nameservers" pointing to your home machine. Your plan is flawed, this isn't a good idea.

  3. #3
    Join Date
    Apr 2004
    Posts
    24
    ok say i had one nameserver to my home machine, what can i do? it still wont make any difference about it working coz i cant even get through to it

  4. #4
    I'm confused as to your setup... Please clarify for me. This is what I understand:

    You have ns1.domain.com with an A record to your home machine (lets call it 10.0.0.1).

    When you connect to 10.0.0.1:53 you get connection refused.

    Is this correct?

  5. #5
    Join Date
    Apr 2004
    Posts
    24
    yes, and the router is all set up fine so the box must be refusting it

  6. #6
    Can you query your own zone at the named server using your own named server ?

  7. #7
    Join Date
    Apr 2004
    Posts
    24
    how can i do that?

  8. #8
    netstat -an | grep -i liste

    any ports 53 here?

    ps -aux | grep named

    ??

    this is the first steps....

  9. #9
    # dig ns1.f0xy.net @82.33.155.48

    ; <<>> DiG 8.3 <<>> ns1.f0xy.net @82.33.155.48
    ; (1 server found)
    ;; res options: init recurs defnam dnsrch
    ;; res_nsend to server 82.33.155.48 82.33.155.48: Connection refused

    firewall???

    nmap -sS -v -p53 82.33.155.48

    Interesting ports on 82-33-155-48.cable.ubr04.wiga.blueyonder.co.uk (82.33.155.48):
    Port State Service
    53/tcp filtered domain

  10. #10
    Join Date
    Apr 2004
    Posts
    24
    no server firewall, and router is forwarding port 53......

    what does the filter mean ??!?!??!!??!

  11. #11
    Show your bind's log file after restart named, pls...

  12. #12
    Join Date
    Apr 2004
    Posts
    24
    this?


    [[email protected] root]# tail -f /var/log/messages
    Apr 12 22:26:15 linuxbox named[3041]: no IPv6 interfaces found
    Apr 12 22:26:15 linuxbox named[3041]: listening on IPv4 interface lo, 127.0.0.1#53
    Apr 12 22:26:15 linuxbox named[3041]: listening on IPv4 interface wlan0, 192.168.1.103#53
    Apr 12 22:26:15 linuxbox named[3041]: command channel listening on 127.0.0.1#953
    Apr 12 22:26:15 linuxbox named[3041]: zone 0.0.127.in-addr.arpa/IN: loaded serial 1997022700
    Apr 12 22:26:15 linuxbox named[3041]: zone localhost/IN: loaded serial 42
    Apr 12 22:26:15 linuxbox named[3041]: zone f0xy.net/IN: loaded serial 1
    Apr 12 22:26:15 linuxbox named[3041]: running
    Apr 12 22:26:15 linuxbox named[3041]: zone f0xy.net/IN: sending notifies (serial 1)
    Last edited by Digi_Err0r; 04-12-2004 at 05:27 PM.

  13. #13
    Join Date
    Apr 2004
    Posts
    24
    /var/named/f0xy.net.zone :

    Code:
    $ORIGIN .
    $TTL 86400      ; 1 day
    f0xy.net        IN SOA  f0xy.net. root.f0xy.net. (
                                    1          ; serial
                                    3600       ; refresh (1 hour)
                                    3600       ; retry (1 hour)
                                    604800     ; expire (1 week)
                                    86400      ; minimum (1 day)
                                    )
    $TTL 259200     ; 3 days
                            NS      ns1.f0xy.net.
    $TTL 86400      ; 1 day
                            A       192.168.1.103
    $ORIGIN www.f0xy.net.
    www                     CNAME   f0xy.net.

  14. #14
    Join Date
    Apr 2004
    Posts
    24
    /etc/named.conf :

    Code:
    // generated by named-bootconf.pl
    
    options {
    	directory "/var/named";
    	/*
    	 * If there is a firewall between you and nameservers you want
    	 * to talk to, you might need to uncomment the query-source
    	 * directive below.  Previous versions of BIND always asked
    	 * questions using port 53, but BIND 8.1 uses an unprivileged
    	 * port by default.
    */
    	 query-source address * port 53;
    listen-on { 127.0.0.1; 192.168.0.0/16; 82.33.155.48; };
    };
    
    // 
    // a caching only nameserver config
    // 
    
    controls {
    	inet 127.0.0.1 allow { localhost; } keys { rndckey; };
    };
    zone "." IN {
    	type hint;
    	file "named.ca";
    };
    
    zone "localhost" IN {
    	type master;
    	file "localhost.zone";
    	allow-update { none; };
    };
    
    zone "0.0.127.in-addr.arpa" IN {
    	type master;
    	file "named.local";
    	allow-update { none; };
    };
    zone "f0xy.net" {
            type master;
            file "f0xy.net.zone";
    
    };
    
    include "/etc/rndc.key";

  15. #15
    Join Date
    Apr 2004
    Posts
    24
    anyone have any ideas?

  16. #16
    Join Date
    Feb 2003
    Posts
    543
    You have gone to your registrar and added the name servers havent you?
    Off Topic Web Forum - A forum for talking about anything!!
    N.Z. Webmaster Community - Are you from New Zealand? Well signup to our forum!!!!

  17. #17
    Join Date
    Apr 2004
    Posts
    24
    yes ns1.f0xy.net and ns2.f0xy.net pointed to my ip - 82.33.155.48

    added successfully, then set my domain to use those namservers

  18. #18
    Originally posted by Digi_Err0r
    no server firewall, and router is forwarding port 53......

    what does the filter mean ??!?!??!!??!
    That means that your 53 port may be filtred by smth.
    Ask your ISP about it....

    Originally posted by Digi_Err0r
    [[email protected] root]# tail -f /var/log/messages
    Apr 12 22:26:15 linuxbox named[3041]: no IPv6 interfaces found
    Apr 12 22:26:15 linuxbox named[3041]: listening on IPv4 interface lo, 127.0.0.1#53
    Apr 12 22:26:15 linuxbox named[3041]: listening on IPv4 interface wlan0, 192.168.1.103#53
    Apr 12 22:26:15 linuxbox named[3041]: command channel listening on 127.0.0.1#953
    Hmm... where is your listening 82.33.155.48 on 53 port?

    netstat -an | grep LIST

    ???

    Originally posted by Digi_Err0r
    query-source address * port 53;
    listen-on { 127.0.0.1; 192.168.0.0/16; 82.33.155.48; };
    };
    Try this

    # query-source address * port 53;
    listen-on port 53 { 127.0.0.1; 192.168.0.0/16; 82.33.155.48; };
    };

    give log again after it, pls

  19. #19
    Join Date
    Apr 2004
    Posts
    24
    rite, i checked the router logs, and i see all the requests coming thru on 53, and being forwarded to the server fine.

    so this means the server is not listening correctly....

    when i do

    netstat -an | grep 53

    i dont see 82.33.155.48 ( my external ip ) anywhere... its in the listen-on thing, but its not showing....

    do i have to add an ip alias? how do i do that?

    thanks

  20. #20
    Don't try to tell your named server listen on non-exist ip address on your box, this case it is 82.33.155.48 . This ip belong to your router. You try to create a ip 82.33.155.48 is worst, because if you do it right it will conflit with your router box.

    For now just remove the listen-on options off. This way named server will listen to any ip, which are alive at your box.

    1. Remove the listen-on options for now.
    2. make sure you can query your zone with in your local net. If it works then your bind work properly, and trouble shoot some thing else beyond your router box.

    hope it helps

  21. #21
    Join Date
    Apr 2004
    Posts
    24
    hey,

    well i removed the listen on lines, and tried various dig commands, like ' dig @82.33.155.48 f0xy.net ' , ' dig @192.167.1.103 f0xy.net ' and ' dig @127.0.0.1 f0xy.net ' which all returned the correct nameserver and info etc.. but whenever anyone lese tries the '82.33.155.48' all they get is, The Server Could Not Be Reached, or they get a timeout.

    So i looked at the router logs, and its shows the requests coming thruogh and being forwarded to the correct LAN ip fine ( see picture attached ).

    Seeing that the requests were coming through fine i went back to the linux box and did a 'tcpdump -i wlan0 port 53' and asked somebody to request the domain while that command was running. I got this:

    Code:
    [[email protected] root]# tcpdump -i wlan0 port 53
    tcpdump: listening on wlan0
    22:46:44.227111 ns1-edi.blueyonder.net.33803 > linuxbox.domain:  9208 A? www.f0xy.net. (30) (DF)
    22:46:44.229414 linuxbox.32912 > wrt54g.domain:  11154+ PTR? 39.64.31.62.in-addr.arpa. (42) (DF)
    22:46:44.512873 wrt54g.domain > linuxbox.32912:  11154 1/0/0 PTR[|domain] (DF)
    22:46:44.523523 linuxbox.32912 > wrt54g.domain:  11155+ PTR? 1.1.168.192.in-addr.arpa. (42) (DF)
    22:46:44.526285 wrt54g.domain > linuxbox.32912:  11155 1/0/0 PTR[|domain] (DF)
    22:46:45.187320 ns1-udd.blueyonder.net.domain > linuxbox.domain:  15116 [1au] A? www.f0xy.net. (41) (DF)
    22:46:45.192383 linuxbox.32912 > wrt54g.domain:  11156+ PTR? 39.112.31.62.in-addr.arpa. (43) (DF)
    22:46:45.195231 wrt54g.domain > linuxbox.32912:  11156 1/0/0 (79) (DF)
    22:46:45.427109 ns1-edi.blueyonder.net.33803 > linuxbox.domain:  23636 A? www.f0xy.net. (30) (DF)
    22:46:46.102589 ns1-gat.blueyonder.net.domain > linuxbox.domain:  21047 A? www.f0xy.net. (30) (DF)
    22:46:46.112510 linuxbox.32912 > wrt54g.domain:  11157+ PTR? 39.144.31.62.in-addr.arpa. (43) (DF)
    22:46:46.115608 wrt54g.domain > linuxbox.32912:  11157 1/0/0 (79) (DF)
    22:46:46.225553 ns1-gat.blueyonder.net.domain > linuxbox.domain:  18773 A? www.f0xy.net. (30) (DF)
    22:46:46.646415 ns1-edi.blueyonder.net.33803 > linuxbox.domain:  42503 A? www.f0xy.net. (30) (DF)
    22:46:47.401178 ns1-gat.blueyonder.net.domain > linuxbox.domain:  2749 A? www.f0xy.net. (30) (DF)
    22:46:47.829239 ns1-edi.blueyonder.net.33803 > linuxbox.domain:  35258 A? www.f0xy.net. (30) (DF)
    22:46:48.601585 ns1-gat.blueyonder.net.domain > linuxbox.domain:  50539 A? www.f0xy.net. (30) (DF)
    22:46:48.997025 ns1-udd.blueyonder.net.domain > linuxbox.domain:  15116 A? www.f0xy.net. (30) (DF)
    22:46:56.983672 ns1-udd.blueyonder.net.domain > linuxbox.domain:  15116 A? www.f0xy.net. (30) (DF)
    
    19 packets received by filter
    0 packets dropped by kernel
    That happens when someone tries to get to the domain in IE.

    So that must mean the requests are coming to the server just fine, but for some reason the server wont accept the requests.

    what could be the matter now?

    thanks
    Attached Thumbnails Attached Thumbnails logs.gif  

  22. #22
    Look...

    I see you havn't any real IP on your linuxbox... but 82.33.155.48 is your router...

    How do you think what does it mean?

    You DNS in your local net works fine... but when i try to dig @82.33.155.48 any_host i am requesting your router...

    You must show off your real IP for inet ...

    You must bind your adress 82.33.155.48 to your netcard & make your router run as a bridge. It seems to me it is easier way to resolve your problem...

  23. #23
    Join Date
    Apr 2004
    Posts
    24
    well, no it cant be that because when someone requests the domain, its coming through the router and the requests are then going to the linux box. The prob is that the linux box isnt responding, and when it tried to the router is blocking it, or in other words not letting the packets back out. i think i need a tunnel or something?!?

  24. #24
    Just curious, what type is the router ?

  25. #25
    Join Date
    Apr 2004
    Posts
    24
    linksys wmp54g

  26. #26
    Every thing work fine now ?

  27. #27
    Join Date
    Apr 2004
    Posts
    24
    no because i cant set up a tunnel, im tryin to figure out SNAT and DNAT

  28. #28
    Are you running redhat 9. It is posible that during you install redhat 9, you turn on iptables, and (I think) maybe iptables default block named traffic ? at shell type

    hostname:>sudo iptables --list

    to see if iptables is on and their behavior.

    or

    hostname:>sudo service iptables status

    If it is on and turn it off, if you dont know much about iptables, if you are expert in iptables, take advantage of it.

    If I was you I put 2 nic cards in the box, one connect to the broadband modem, and one for internal network , using SNAT, and use iptables as a firewall. I believe iptables is more flexible, more features than the one builded in firewall in linksys box.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •