Results 1 to 9 of 9
  1. #1
    Join Date
    Jan 2004
    Posts
    45

    Question PureFTP - How to increase file limits list (2000 entries)?

    Hello,

    How to increase file limits list (2000 entries)? I edit /etc/pure-ftpd.conf and change line 164 to:

    # 'ls' recursion limits. The first argument is the maximum number of
    # files to be displayed. The second one is the max subdirectories depth

    LimitRecursion 5000 15

    But when i list the directory, continue show this error:

    226-Options: -l
    226 Output truncated to 2000 matches
    ftp>

    Any idea?

    Regards,
    Minotauro.

  2. #2
    "pure-ftpd -L <OPT>"
    you could put that option directly in rc script.

    regards,
    Powered by AMD & FreeBSD.
    "Documentation is like sex:
    when it is good, it is very, very good;
    and when it is bad, it is better than nothing."

  3. #3
    Join Date
    Jan 2004
    Posts
    45
    Originally posted by Miha
    "pure-ftpd -L <OPT>"
    you could put that option directly in rc script.

    regards,
    Hello Miha,

    Look it:

    [email protected] [/etc]# pure-ftpd -L 1000
    421 Configuration error: Illegal 'ls' limits: 1000
    [email protected] [/etc]#

    Any idea? I try other values too...

    Thanks by reply,
    Minotauro.

  4. #4
    Join Date
    Jul 2001
    Location
    Singapore
    Posts
    1,790
    Have you restart pure-ftpd after making changes in the configuration?
    Giam Teck Choon
    :: Join choon.net Community today to share your tips and tricks on server issues please ::
    :: Singapore Dedicated Servers :: Singapore Virtual Private Servers :: Linux/FreeBSD Server Management ::

  5. #5
    Originally posted by minotauro
    Hello Miha,

    Look it:

    [email protected] [/etc]# pure-ftpd -L 1000
    421 Configuration error: Illegal 'ls' limits: 1000
    [email protected] [/etc]#

    Any idea? I try other values too...

    Thanks by reply,
    Minotauro.
    the format is "-L max files:max depth"

    so it would look something like:
    "pure-ftpd -L 10000:10" for 10k files limit and 10 dirs for recursion limit.

    regards,
    M.
    Powered by AMD & FreeBSD.
    "Documentation is like sex:
    when it is good, it is very, very good;
    and when it is bad, it is better than nothing."

  6. #6
    Join Date
    Jan 2004
    Posts
    45

    *

    Hello Miha,

    Sorry by stupied question, but i receive this:

    [email protected] [/etc]# pure-ftpd -L 10000:10
    Unable to start a standalone server: Address already in use
    [email protected] [/etc]#

    I try stopped the pureftpd but dont work...

    Regards,
    Minotauro.

  7. #7
    Join Date
    Jul 2002
    Location
    Alberta, Canada
    Posts
    348
    Its possibly running via inetd or xinetd... in which case you will have to disable it in the config for it first.
    AC Host Canada Affordable Canadian Web Hosting Solutions
    Shared Hosting | Email Hosting | DNS Hosting | Custom Plans Available
    Website: www.achost.ca email: [email protected]

  8. #8
    Join Date
    Jan 2004
    Posts
    45
    Originally posted by achost_ca
    Its possibly running via inetd or xinetd... in which case you will have to disable it in the config for it first.
    Hello achost_ca,

    Thanks very much! I edit the /etc/sysconfig/pure-ftpd and insert the line to increase the file list...

    Regards,
    Minotauro.

  9. #9
    Originally posted by minotauro
    Hello achost_ca,

    Thanks very much! I edit the /etc/sysconfig/pure-ftpd and insert the line to increase the file list...

    Regards,
    Minotauro.
    Can you guys tell me what line to insert into /etc/sysconfig/pure-ftpd?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •