Results 1 to 6 of 6
  1. #1

    help with multiple ip's

    i have a dedicated server with 5 ip's.. ex. is set up as main ip for server .200-.204 are my remaining ip's.. i set up accounts for each of these so that my clan can have different game servers at once running.. i can log individually into each account ftp.ssh ect.. but when i try to run a game americas army on each ip they wont run. so turned all off and only run one still only ip it will run on is the main one .200.. even though i install it in another account with different ip.. how do i go about allocating the ip so that i can run different servres on it?

  2. #2
    Join Date
    Apr 2004
    We have the same problem too. Any help on this matter would be gratefully appreciated

  3. #3
    Join Date
    Aug 2002
    Are you trying to run all of them on the same port? If so, that's not going to work. Run them on different ports, see if that works.

    - Matt

  4. #4
    Join Date
    Apr 2004
    Managed to work this out. This worked for me may not work for every one

    My main ip is
    The one i wanted the game to run on is

    Part of my server.ini dealing with IP

    [URL] <-- add this line to server.ini changing the ip to the ip you want to use
    ProtocolDescription=Unreal Protocol

    ;(delete the ';' in front of 'IP=' when setting your IP) <--Set ip you want registered with gamespy
    bNAT=False <-- I set this to false dont know if it makes any difference

    ;(delete the ';' in front of 'IP=' when setting your IP) <-- set this for andromeda

    Upload the server.ini using ssh <-- dont know if you can just ftp the file have not tried yet

    Using ssh cd to the aao system folder you installed aao on e.g. /home/aao/System

    Run this command

    ./server-bin global Insurgent_Camp.aao -nohomedir -INI=server.ini

    After i had did the above i was able to log into aao using the .89 ip instead of the .80 ip

    Hope this helps let me know if it does

  5. #5
    Join Date
    Jul 2003
    It is worth noting that some games such as RavenShield will only run on the first IP

    Multihome works but only about half the time for RVS..

  6. #6
    I know this is an older thread.

    I just wanted to say this actually worked FLAWLESSLY for me.

    Thanks for the help, searched all around and literally nothing worked, people had similiar things I think what did it was forcing the port to the end of the multihome variable as thats the only things i saw different between other peoples tutorials and this one.

    Again thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts