Results 1 to 5 of 5
  1. #1

    Question SSH Password failed for every user

    Hi there,
    I am using cpanel in one of my machine. I am facing a problem; user cannot connect through SSH saying "Password Authentication Failed". I have checked by creating a new user and the case is the same. Where as i can connect through FTP with the same password; but SSH i donno what's the problem.

    Note: root can connect through SSH.

    Any help will be much appreciated.

  2. #2
    Join Date
    Apr 2004
    Posts
    96
    Do they have SSH Access Enabled through WHM? Its off by default.

  3. #3
    Join Date
    Nov 2003
    Location
    Marylebone, London, UK
    Posts
    526
    also check their entries in /etc/passwd
    or wherever it is on linux- will show if they
    have a shell, or nologin set

  4. #4
    Yes... shell access is anable for all users and i have checked the
    /etc/passwd
    All entries are there

    here are some of entries:-
    ====
    male7a:x:32022:523::/home/male7a:/usr/local/cpanel/bin/jailshell
    khalid77:x:32018:519::/home/khalid77:/usr/local/cpanel/bin/jailshell
    khyaal:x:32023:524::/home/khyaal:/bin/bash
    raseel:x:32024:525::/home/raseel:/usr/local/cpanel/bin/jailshell
    alawthak:x:32025:526::/home/alawthak:/usr/local/cpanel/bin/jailshell
    kbadr:x:32027:528::/home/kbadr:/usr/local/cpanel/bin/jailshell
    ====

  5. #5
    Hi,

    You need to set more users in your AllowUsers directive in /etc/ssh/sshd_config file. This entry is found at the end of the file. More than likely you have this there now:

    AllowUsers root

    Change it to:

    AllowUsers root user1 user2 user3 user4 otheruser anotheruser

    Restart SSHd and type:

    bash or logout and log back in.

    Becareful restarting SSHd, because if it doesn't come back up you'll be locked out of your machine. Enable telnet before doing this, and make sure it works.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •