Results 1 to 9 of 9
  1. #1
    Join Date
    Feb 2004
    Location
    Bay Area, CA
    Posts
    521

    FreeBSD make installworld errors

    Wondering if anyone can help me out. I'm gettin stuck on updating my FreeBSD system. Everything works well right up to make installworld. About 40 seconds through I get this error:

    Code:
    ===>bin
    ===>bin/cat
    install -c -s -o root -g wheel -m 555 cat /bin
    /usr/obj/usr/src/i386/usr/libexec/elf/strip: /bin/stuQDdza: Operation not
    permited
    install: wait: Operation not permitted
    ***Error code 70
    
    Stop in /usr/src/bin/cat.
    ***Error code 1
    I'm in single user mode with securelevel off. Not sure what else could be causing it. Any ideas?

  2. #2
    Join Date
    Jan 2002
    Location
    Dallas, TX
    Posts
    244
    Well it's definitly a permissions issue. I ran into a similar issue once before and it turned out I had "noexec,nosuid" on my /tmp partition in my /etc/fstab. what I had to do was temporarly remove those options from the /etc/fstab and run the make installworld and then add those options back when finished.

    You might also want to as your questions on bsdforums.org which is a great forum for questions on the BSDs.

    Let me know if this works or if you need more help

    Kevin

  3. #3
    Join Date
    Feb 2004
    Location
    Bay Area, CA
    Posts
    521
    Cool, i'll check out the Bsdforums and check out the fstab. Thanks for your input!

  4. #4
    Join Date
    Feb 2004
    Location
    Bay Area, CA
    Posts
    521
    everything is mounted read/write. can't see any reason it would be a permission error looking at the filesystem =\

  5. #5
    Have you tried doing this
    cat /bin
    /usr/obj/usr/src/i386/usr/libexec/elf/strip: /bin/stuQDdza

    and check permissions ?
    Datums Internet Solutions, LLC
    Systems Engineering & Managed Hosting Services
    Complex Hosting Consultants

  6. #6
    Join Date
    Jan 2002
    Location
    Dallas, TX
    Posts
    244
    Ok,

    Here are my thoughts. A few months ago I had the issue that I pasted below and it turned out I had ran the following command a few days before I started having trouble with make installword. Does your /sbin/init have the immutable flag set?
    Try "ls -lo /bin/stuQDdza" To find out.

    (Command that caused problems for me)

    chflags schg /sbin/*

    ie: in your case it might've been "chflags schg /bin/*"

    (Error message that i had when I tried to run make installworld afterwards).

    install: rename: /sbin/init to /sbin/init.bak: Operation not permitted
    *** Error code 71

    Stop in /usr/src/sbin/init.

    (Command that actually fixed the issue for me)

    chflags noschg /sbin/*

    ie: This might work in your case "chflags noschg /bin/*


    After your make installworld you can then set it back to "chflags schg /bin/*" once again if this is actually what you had set and then disable it once again when you do another make installworld.


    Here's what all this stuff does just to give you a little background. The commands below are used for file system security:

    chflags schg /bin/*
    chflags schg /sbin/*
    chflags schg /usr/sbin/*

    Here's what they all mean:

    schg - set the system immutable flag (superuser only)
    The system-level immutable flag can only be set or removed by root. Files with this flag set cannot be changed in any way: not edited, not moved and not replaced. Basically, the kernel will prevent all attempts to touch this file. This flag cannot be removed when the system is running at securelevel 1 or greater.

    The superuser-settable "schg" flags can be set at any time by issuing "noschg" instead of "schg", but may only be cleared when the system is running at security level 0 or -1 (insecure or permanently insecure mode, respectively). The securelevel is normally set to 0, for example, when running in single-user mode.


    Hope this helps and I wasn't too confusing or long-winded. Let me know if I could help any further.

    Kevin
    Last edited by DaHOST; 04-04-2004 at 03:37 AM.

  7. #7
    Join Date
    Feb 2004
    Location
    Bay Area, CA
    Posts
    521
    THis makes much more sense. Since before this all started I was doing some security tightening. I bet those flags were set. I'll check out the permissions for it. Thanks!

  8. #8
    Join Date
    Feb 2004
    Location
    Bay Area, CA
    Posts
    521
    I think I found my problem.

    stuQDdza: this file doesnt exist.

    Everytime I make installworld this filename changes names. But it is never in my /bin dir. What could be causing this?

  9. #9
    Join Date
    Feb 2004
    Location
    Bay Area, CA
    Posts
    521
    ah HA. you guys were on the right track. I had schg set on the /bin itself, not everything inside it. I did chflags noschg /bin and everything started working. Thanks for the help everyone!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •