Results 1 to 14 of 14
  1. #1
    Join Date
    Dec 2003
    Location
    Chile
    Posts
    31

    High serverload problem...

    Hi dudes, well i need some help here...

    i have a Athlon XP 2600+ server with 1 gb ram (currently using just 879 Mb because linux kernel...)

    my server are running a website with a big forum (invision board) and have like 10.000 registered users, like 300-400 users online all the time, etc...

    im using apache+mysql and this my problem:

    http://www.enex.tie.cl/serverload.jpg

    99% CPU usage (all the time)

    and 99% Ram usage (all the time)

    what i can do?

    PD: Is a full server just for this site, not shared hosting.

  2. #2
    Join Date
    Mar 2003
    Location
    California USA
    Posts
    13,290
    sounds like the server isent powerful enough to do the sites. Im guessing the amd has 256k cache i dont remember if that series does, but that does no good on mysql querys. Have you tried optimizing your mysql config? or you httpd conf?

    try throwing this in your /etc/my.conf and restarting mysql.

    [mysqld]
    skip-locking
    key_buffer=60M
    join_buffer=1M
    record_buffer=1M
    sort_buffer=2M
    table_cache=1028
    max_connections=250
    thread_cache_size=286
    max_allowed_packet=5M
    connect_timeout=15
    query_cache_limit=1M
    query_cache_size=32M
    query_cache_type=1
    thread_concurrency=2
    wait_timeout=15

    Also install turk mmcache, it will help out greatly. Do you have keepalives on or off on your httpd config? Another thing you could do is run thttpd and have it serve your image files and leave apache for the pages.
    Steven Ciaburri | Industry's Best Server Management - Rack911.com
    Software Auditing - 400+ Vulnerabilities Found - Quote @ https://www.RACK911Labs.com
    Fully Managed Dedicated Servers (Las Vegas, New York City, & Amsterdam) (AS62710)
    FreeBSD & Linux Server Management, Security Auditing, Server Optimization, PCI Compliance

  3. #3
    Join Date
    Jul 2001
    Location
    /dev/null
    Posts
    1,219
    Install kernel-bigmem to get the rest of our memory back.

  4. #4
    Join Date
    Dec 2003
    Location
    Chile
    Posts
    31
    thanks thanks thanks!

    i dont know too much about httpd and mysql config so dont move that configs... just default settings i think.

    btw, the cpu have 512 cache.

    I try now with thelinuxguy mysql config and see what happend.

    what about keepalives? i have to setup it on or off?

    Thanks in advance!

  5. #5
    Join Date
    Dec 2001
    Location
    Hanoi - Vietnam
    Posts
    306
    Install Turck MMCache, will help a lot.

    How to setup thttpd to serve static file and Apache for the rest?

  6. #6
    Hi

    Invision board takes lots of resources when having more than 10,000 users LOL..I prefer to tune mysql especially with query cache parameters in the /etc/.my.cnf . Also see if you can increase your RAM to 2 GB.
    Arnold Mathews
    Senior Linux Engineer
    SupportSupply.com Outsourcing
    http://www.SupportSupply.com

  7. #7
    Join Date
    Dec 2003
    Location
    Chile
    Posts
    31
    well i have one licence of Vbulletin Board, and i dont use it, what you think is more stable?

    maybe i should move my forum to vbulletin?

    now i hate the message "Sorry, the server is busy now, please try again in another moment"... blah blah...

    i will install Turck MMCache as a first step

  8. #8
    Hi

    Well the issue is not with the boards moving boards will make no help instead in errors being on the same server. Try to tune mysql or increase RAM.
    Arnold Mathews
    Senior Linux Engineer
    SupportSupply.com Outsourcing
    http://www.SupportSupply.com

  9. #9
    Join Date
    Apr 2001
    Location
    Palm Beach, FL
    Posts
    1,095
    Show us what your top screen looks lile. You might have a runaway process.
    Alex Llera
    Professional Server Management
    FreeBSD|Linux|HSphere|Cpanel|Plesk

  10. #10
    Join Date
    Dec 2003
    Location
    Chile
    Posts
    31
    Here is:

    http://www.enex.tie.cl/servertop.gif

    Take note that in this moment i have less movement in the board, because here is sunday in the morning...

  11. #11
    Thats alot of http processes, like thelinuxguy said you need to optimize http and mysql for such heavy use, what are you current http settings and have you install truck mmcache yet ?
    http://www.baddabinghosting.com
    [email protected]
    MSN - [email protected]
    AIM - Badda Bing 0003

  12. #12
    Join Date
    Dec 2003
    Location
    Chile
    Posts
    31
    http://www.enex.tie.cl/httpd.conf.txt

    Turck MMCache not installed yet.

  13. #13
    Try these settings for httpd.conf

    MaxRequestsPerChild 500
    StartServers 10
    MinSpareServers 10
    MaxSpareServers 30
    KeepAliveTimeout 5 (i'm kinda ify on this setting so if you start to see load climbing even higher after this is set to 5 change it back to 15)
    Timeout 15 (again same thing applies)

    Maybe someone else can give you better settings all I know is I used these on a customers site which was huge and the load was very minimal. Truck Mmcache also was installed, get that installed ASAP.
    http://www.baddabinghosting.com
    [email protected]
    MSN - [email protected]
    AIM - Badda Bing 0003

  14. #14
    Join Date
    May 2003
    Posts
    472
    if you look at his top, apache isnt his problem - mysql is. Try the following:

    - update mysql to latest version ( 4 )
    - do everything listed at http://forums.ev1servers.net/showthr...threadid=20983

    I would definately recommend using vBulletin for a forum as large as yours, it is designed to handle many users better, which is why pretty much every large forum I see uses vBulletin.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •