Results 1 to 4 of 4
  1. #1

    MySQL issues with /var/lib/mysql/mysql.sock

    Hey guys,

    I'm having major issues with MySQL on a network for my local campus.

    I was asked to install MySQL but am having issues. I tried the basic uploading of all RPMs (through SFTP) and starting rpm -i MySQL* but found myself with apparent conflicts. I looked to see if MySQL was already installed and sure enough it was. However, I'm receiving the infamous error:

    [[email protected] mysql]# mysql
    ERROR 2002: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
    I tried to locate -u mysql.sock but that came up empty.

    So far I have been able to rpm -e most of the ones found while running rpm -qa | grep -i mysql . I got down to:
    [[email protected] lib]# rpm -qa | grep -i mysql
    before I could not install because mysql-3.23.36-1 said it couldn't be uninstalled because of a dependency by php-mysql-4.0.4pl1-9, yet that file claimed to be uninstalled while running rpm -e.

    If anyone could post suggestions on how to completely remove this previous installation, I have all 4 necessary (new) RPMs waiting to be installed...



  2. #2
    Join Date
    Jun 2003
    Try rpm -e --force Mysql etc... MAke sure you have a backup of /var/lib/mysql as well

    Also you could just try /etc/init.d/mysql start

    Russ Foster - Industry Curmudgeon

  3. #3

    Thanks for your reply but you cannot force a deletion. Also our server does not contain a mysql folder in the /etc/init.d folder.


  4. #4
    GREAT! I was able to get MySQL fully reinstalled, but NOW I CAN'T CONNECTED. I gave the installation no parameters during for the password during installation but now I can't connect to do anything and every site online telling me how to reset the root pass has been useless.

    Can anyone help?!


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts