Results 1 to 12 of 12
  1. #1

    Local Safe Mode but Global Not

    Local Safe Mode but Global Not

    Hi there all,

    I run a software house, so I host some of the clients, not too public but have about 100 domains hosted in there.

    Anyway, I have clients that need their safe mode to be off,
    so what I did was to add "php_admin_value safe_mode off" to this section after <module php4> in httpd.include

    But sadly, it only works till the plesk overwrites it.

    Anyway suggestions that i can keep it permanent?

    Thanks

  2. #2
    Join Date
    Jan 2002
    Location
    Home, chair
    Posts
    723
    Try inserting this into each VirtualHost section, this shouldn't overwritten.

  3. #3

    Thanks but please advice...

    Thank you for your reply.

    But sorry to impose but how do you exactly do that?

    1.2.3. Steps will be appreciated as I am not really a server admin here, just trying to solve the problem.

    Thanks in advance.

  4. #4
    Join Date
    Jan 2002
    Location
    Home, chair
    Posts
    723
    Well, find the section in httpd.include that starts with:

    <VirtualHost>
    and ends with
    </VirtualHost>

    and is related to one of the domains on your server, you will see there a line that says:
    ServerName www.domain.com

    and insert that line there in your first post, then save and restart apache. This will disable safe mode for that particular domain.

  5. #5
    thanks.. but will the plesk rewrite it when I make a new domain or in a couple of days.

    What i mean is that will it this safemode method be permanent?

  6. #6
    one more sir, should it be <xx.xx.xx.xx:443> or <xx.xx.xx.xx:80>

    as what i had done was placing that command in <xx.xx.xx.xx:80>
    <IfModule mod_php.4.c>
    in between of

    php_admin_flag engine on
    <--------------------------------> placed here
    php_admin_value open_basedir "xxxxxx"

    and it didnt last

  7. #7
    Join Date
    Jan 2002
    Location
    Home, chair
    Posts
    723

  8. #8
    sigh..
    tried .. failed

    I have placed

    <VirtualHost xx.xx.xx.xx:80>
    Server name xxxxxx
    redirectpermanent / http://xxxxxxxx
    php_admin_value safe_mode off
    </virtualhost>

    Please correct me if I am wrong

    Checked with phpinfo.php

    safe_mode local On Global On

  9. #9
    Join Date
    Jan 2002
    Location
    Home, chair
    Posts
    723

  10. #10
    yup

    Anything wrong with this?

    <VirtualHost xx.xx.xx.xx:80>
    Server name xxxxxx
    redirectpermanent / http://xxxxxxxx
    php_admin_value safe_mode off
    </virtualhost>

  11. #11
    Join Date
    Feb 2004
    Posts
    772
    Hi,

    Editing "safe mode" options in php.ini may work for global changes.

    Regards,

    Bright

  12. #12
    Originally posted by
    Hi,

    Editing "safe mode" options in php.ini may work for global changes.
    when will you learn to read the whole thread and not just spam the board with your posts?

    In any case,

    Originally posted by
    as what i had done was placing that command in <xx.xx.xx.xx:80>
    <IfModule mod_php.4.c>
    in between of

    php_admin_flag engine on
    <--------------------------------> placed here
    php_admin_value open_basedir "xxxxxx"

    Try placing the php_admin_value just before </virtualhost> instead of within the IfModule section and restart Apache .
    Like us on Facebook to qualify for discounts!
    http://www.sprintserve.net
    Offering: | Internap FCP Bandwidth! | Rebootless Kernel Updates! | Magento Optimized Hosting | Wordpress Hosting |
    Services: | Managed Multiple Cores 64bit Servers | Server Management |

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •