Results 1 to 2 of 2
  1. #1
    Join Date
    Sep 2000
    San Diego's North County


    My troubles with my new dedicated server are growing. Other than the problems mentioned in the general forum with CGIs being unable to execute (they work via telnet, but not via the web), I've found that my SSIs are not appearing and my password-protected directory will not let me in using ANY of three user/pass combos created!!! This is all using the Linux/Apache/Plesk combo at I'm beginning to think that something is seriously wrong with the server config... (and that I'm not *near* savvy enough to run my first dedicated server, even with a "control panel").


    William Morton
    Second Glance

  2. #2
    Join Date
    May 2000
    Montreal, Quebec, Canada
    Hi Shooter,

    definitely a config problem.

    If linuxconf is installed on the server you can verify the default Apache config using it. You might want to make sure that "cgi" and "ssi" are enabled and that your alias for the "cgi-bin" is set up correctly. Also make sure that your cgi-bin is chmod 755 to allow you to execute scripts contained in it:

    chmod 755 cgi-bin

    For the password protected directory, all you have to do is add the users to the .htaccess file that you want to give access to.

    To see the .htaccess file you have to use the following command to show hidden files:

    ls -ails

    And to edit it you can use pico or vi:

    pico .htaccess

    And then add the following to add a user to it:

    require user username

    Where username is any user you want to grant access to.

    Here is a sample of a basic .htaccess file:

    AuthType Basic
    AddHandler cgi-script .cgi
    AuthName "Enter At Your Own Risk!"
    require user frank
    require user john

    Hope this helps.

  3. Newsletters

    Subscribe Now & Get The WHT Quick Start Guide!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts