Results 1 to 2 of 2
  1. #1
    Join Date
    Mar 2004

    Problem Installing SuExec on Apache2

    i've installed Apache2 with PHP 4 support and now i want to securise my CGI using suexec solution ,so i downloaded the relative docs of suexec installation and i made this :

    # service httpd stop
    # ./configure --prefix=/usr/local/httpd --enable-deflate --enable-so --enable-mods-shared=all --enable-suexec --with-suexec-bin=/usr/local/httpd/bin/ --with-suexec-caller=nobody --with-suexec-docroot=/usr/local/httpd/htdocs/ --with-suexec-logfile=/usr/local/httpd/logs/suexec_log
    # make
    # make install
    (caller=nobody) :arrow: it's the user under wich my Apache's working

    All is done and no errors given
    so i test if suexec is on by typing :
    # ls -alF /usr/local/httpd/bin/suexec
    -rwsr-xr-x 1 root root 48903 mar 24 20:21 /usr/local/httpd/bin/suexec*
    it's ok.
    but in the doc of httpd ,it says that i must have a [notice] in the error log of apache saying that suexec was successfully charged :
    # cat /usr/local/httpd/logs/error_log
    [Wed Mar 24 20:21:26 2004] [notice] Digest: generating secret for digest authentication ...
    [Wed Mar 24 20:21:26 2004] [notice] Digest: done
    [Wed Mar 24 20:21:27 2004] [notice] Apache/2.0.48 (Unix) DAV/2 PHP/4.3.4 configured -- resuming normal operations
    there's no notice !

    another test ,here's the built in modules of my apache :
    # /usr/local/httpd/bin/apachectl -l
    Compiled in modules:
    there's no suexec

    anyone got a solution for me ?
    thanks anyway

  2. #2
    Join Date
    Feb 2003
    If you had statically compiled mod_suexec then you could run the following to double-check your compile options (-V flag to httpd):
    [email protected]:/usr/local/apache2/bin# ./httpd -V | grep suexec
     -D SUEXEC_BIN="/usr/local/apache2/bin/suexec"
    Running ./configure --help helps us out:
    --with-suexec-bin       Path to suexec binary
    So --with-suexec-bin refers to the binary of the resulting suexec binary, not just the path. The correct configure line would have been:
    # ./configure --prefix=/usr/local/httpd --enable-deflate --enable-so --enable-mods-shared=all --enable-suexec --with-suexec-bin=/usr/local/httpd/bin/suexec --with-suexec-caller=nobody --with-suexec-docroot=/usr/local/httpd/htdocs/ --with-suexec-logfile=/usr/local/httpd/logs/suexec_log
    Email / AIM: [email protected] / whoisquasi

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts