Results 1 to 7 of 7
  1. #1

    Apache won't start, nothing in error_log, HELP?!?

    Ok, here's what happened... I came home after being out of the office this afternoon to find the server down. By looking at teh access log timestamp, looks like it went down at 2:30 ESD. I tried starting it and found it complaining about log file size. I gzipped the logs and deleted a couple of domain logs and the error_log. When I deleted those I did also delete the bytes and bytes.offset which I hope wasn't a mistake.

    When it still wouldn't start after deleting the files, I touched all three files, the domlog itself, the -bytes_log, and the -bytes_log.offset. After doing that, still nothing. In the error_log all I get is the PID warning about overwriting the PID file. So it creates the PID, but apache still ends up not running.

    I've tried reboots, commenting out the virtual entries dealing with the logs that I've messed with, re-compiling apache and so on, still teh same mess. It says it started it (httpd start), but it's not there and I have no real errors to go off of. I did chagne the error_log level to debug to try and see if it just wasn't outputting it, but that changed nothing in the logs.

    Any help or can anyone point me in a direction?


  2. #2
    Join Date
    Mar 2003
    California USA
    /usr/local/apache/bin/apachectl configtest
    Get any errors?
    Steven Ciaburri | Proactive Linux Server Management -
    Managed Servers (AS62710), Server Management, and Security Auditing.

  3. #3

    Check the configuration

    Try something like this:

    [[email protected] rk]$ sudo /usr/sbin/httpd -t
    Syntax OK

    That's apache 2... not sure which version you have.

  4. #4
    Not running Apache 2, but I didn't get any errors running the other command. This is definitely a pisser...

  5. #5
    Anyone with any other thoughts? Any help is welcome for sure...


  6. #6
    Join Date
    Jul 2002
    Kolding, Denmark
    Did you try deleting the PID file before starting the httpd service? From what I read you're not on a platform that I know so I don't know how likely you are to end up with a PID file that apache cannot overwrite - but I know that it would usually be a Bad Thing (TM) since a service usually won't start if it can't create a PID file. :-)
    Best regards,

    Anders C. Madsen
    Golden Planet Support -

  7. #7
    Join Date
    Feb 2003
    Some basic but often-overlooked questions: You're root right?! Check your Listen directives, is any other process listening on those IPs/ports? Is there free disk space? Is there enough free memory? Did you recently install some new library? Are you running Apache DSO style? An exact error message when running httpd would help :-)
    Email / AIM: [email protected] / whoisquasi

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts