Results 1 to 3 of 3
  1. #1
    Join Date
    Mar 2004
    Location
    On Planet Halo hunting Aliens.
    Posts
    12

    Angry Direct X problems

    First of all, i use Direct X 9.0b and i have all my drivers and chipsets updated. Somehow, my DirectDraw results were all succesful, but since most of my applications that used Direct3D were not working like games or Benchmarks told me that my graphics card needed more than 4 mb to run, and my card has 64mb and it's a Geforce4 MX 440. Here are the errors i got when trying to test Direct3D:

    Test Failed at Step 8 (creating 3D device) HRESULT= 0x887602eb (error code)

    Test Failed at Step 8 (creating 3D device) HRESULT= 0x8007000e (out of memory)

    Plus i get an error (i don't think it has anything to do with this) that this is not registered or invalid.

    Run-time error '339'

    Component 'mswinsck.ocx' or one of it's dependencies is not correctly registered: a file is missing or invalid.
    Can anyone give me a link were i can register that and download it? I tried registering before but it still didn't help after i did and got the same error!

    Thanks

  2. #2
    Join Date
    Dec 2002
    Location
    NY, NY
    Posts
    3,975
    mswinsck.ocx
    is windows sock, used by many games to connect to the internet

    You can get it here:
    http://www.megasecurity.org/Needed_files/Mswinsck.zip

    Also.. google is your friend ! [http://www.420th.com/temp/google.jpg]

  3. #3
    Join Date
    Feb 2004
    Posts
    772
    Hi,

    Mswinsck.ocx

    You can download it from the following links:
    http://www.it-mate.co.uk/main_content/ocx.asp

    Follow the following steps to register an ocx:
    1) Locate the ocx file in windows explorer.
    2) Select the file and right click on it. Click 'Open With...' from the
    menu.
    3) Click 'Others' button from 'Open with' dialog box.
    4) Navigate to System32 directory and select Regsvr32.exe.
    5) Click Open to select the file. Click Ok on 'Open with' Dialog box.

    OR

    From the DOS prompt, cd to the directory where the OCX file is located and type:

    regsvr32 mswinsck.ocx

    May be it will resolve your problem.

    Regards,

    Bright

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •