Here are the normal ping result for my box @ Mana...
Down for the last 11 Hours.

Normal result:

Pinging 66.79.183.130 [66.79.183.130]:
Ping #1: * [No response]
Ping #2: * [No response]
Ping #3: * [No response]
Ping #4: * [No response]
Done pinging 66.79.183.130!

Weird Results (notice the IP Pinged and the IPs in result)

Pinging 66.79.183.130 [66.79.183.130]:
Ping #1: * [No response]
Ping #2: Got reply from 216.194.27.1 in 783ms [TTL=240]
Ping #3: Got reply from 216.194.27.1 in 40ms [TTL=240]
Ping #4: Got reply from 216.194.27.1 in 43ms [TTL=240]
Done pinging 66.79.183.130!

Pinging 66.79.183.130 [66.79.183.130]:
Ping #1: Got reply from 213.96.195.57 in 754ms [TTL=49]
Ping #2: Got reply from 213.96.195.57 in 180ms [TTL=49]
Ping #3: Got reply from 213.96.195.57 in 177ms [TTL=49]
Ping #4: Got reply from 213.96.195.57 in 177ms [TTL=49]
Done pinging 66.79.183.130!

Pinging 66.79.183.130 [66.79.183.130]:
Ping #1: Got reply from 64.82.11.11 in 47ms [TTL=109]
Ping #2: Got reply from 64.82.11.11 in 52ms [TTL=109]
Ping #3: Got reply from 64.82.11.11 in 52ms [TTL=109]
Ping #4: Got reply from 64.82.11.11 in 52ms [TTL=109]
Done pinging 66.79.183.130!

Pinging 66.79.183.130 [66.79.183.130]:
Ping #1: * [No response]
Ping #2: * [No response]
Ping #3: Got reply from 66.79.173.87 in 577ms [TTL=52]
Ping #4: Got reply from 66.79.173.87 in 68ms [TTL=52]
Done pinging 66.79.183.130!

Pinging 66.79.183.130 [66.79.183.130]:
Ping #1: Got reply from 195.147.88.133 in 814ms [TTL=111]
Ping #2: Got reply from 195.147.88.133 in 163ms [TTL=111]
Ping #3: Got reply from 195.147.88.133 in 162ms [TTL=111]
Ping #4: Got reply from 195.147.88.133 in 133ms [TTL=111]
Done pinging 66.79.183.130!

And after that, someone comes to tell you that all server in that data center are up and running 100%.