Results 1 to 5 of 5
  1. #1
    Join Date
    Feb 2004

    qmail deleted Queue

    ok i had a bad experiance with leaving my server running in open relay (by accident of course)

    i was worried and jumped in and deleted the directorys i ahve replaced them but i know its now because of permissions that its not working

    so i have read up and found out about queue-repair and queue-fix

    but my luck at the mo is terrible

    thats right it wont install queue-fix i get this error after i run the make command:

    make: *** [queue-fix] Error 1

    right then i thought ok i will install python and then try and run the --help and i get this error

    -bash: command not found

    so at the mo im pretty lost i need to fix my queue folders but i cannot install anything to do this ?

    is there a manual process i can do ?

    Mick D

  2. #2
    did you try python ?
    Datums Internet Solutions, LLC
    Systems Engineering & Managed Hosting Services
    Complex Hosting Consultants

  3. #3
    Join Date
    Feb 2004
    yes that got it working

    when i run it, it goes through loads of these:

    found unexpected direntry queue/pid/13412.1079808231.1; ignoring

    then it finishes... does that look ok ?

    thanks very much i am a newbie remember

    right now it sends mails from outlook but it seems to be in the queue and not being sent ?

    this is my qmailctl stat:

    /service/qmail-send: up (pid 11138) 1 seconds
    /service/qmail-send/log: up (pid 4855) 1538 seconds
    /service/qmail-smtpd: up (pid 10489) 117 seconds
    /service/qmail-smtpd/log: up (pid 4848) 1539 seconds
    messages in queue: 4
    messages in queue but not yet preprocessed: 23

    and its growing

    i thought it would deliver them right away ?

    cheers thanks very much

  4. #4
    Join Date
    Feb 2004

  5. #5
    Join Date
    Feb 2004
    ok still no joy

    it wont send mail to anyone now

    i have run queue-repair but i am sure its not doing it right as its telling me not fixed about things

    how do i run it not in test mode ?

    i run this

    python queue-repair --repair

    anyone experianced with this kinda problem ?

    thanks again

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts