Results 1 to 10 of 10
  1. #1
    Join Date
    Mar 2004
    Posts
    20

    Insecure dependency in chdir while......

    Hi fellas

    I think there's a slight bug in the latest RELEASE version of cPanel 9. A client of mine wanted to check stats with Webalizer or Analog Stats, and got this message:

    Insecure dependency in chdir while running with -T switch at cpsrvd.pl line 782, line 131.

    Now I checked the log for /scripts/upcp and I see that cPanel was updated yesterday night to the latest RELEASE version. Upon "downgrading" to the STABLE tree, and reupdating, everything was back to normal.

    Has anyone else experienced this problem?

  2. #2
    Join Date
    May 2003
    Location
    Kirkland, WA
    Posts
    4,448

  3. #3
    Why don't you open a ticket? The consolidation of all the 3 daemons into 1 didn't go very well and there's lots of bugs to work out I am sure.

    But I don't think cpanel runs their code in tainted mode. I will have to go check that one out.
    Like us on Facebook to qualify for discounts!
    http://www.sprintserve.net
    Offering: | Internap FCP Bandwidth! | Rebootless Kernel Updates! | Magento Optimized Hosting | Wordpress Hosting |
    Services: | Managed Multiple Cores 64bit Servers | Server Management |

  4. #4
    Join Date
    Mar 2004
    Posts
    20
    Perl 5.8.1

    As I said in my ^ post, this problem only appeared when cPanel upgraded itself to the latest RELEASE version, which is a few hours ago. Before that everything was fine, and now that I put back the STABLE version everything is fine as well.

    Just thought it was weird that cPanel was causing this problem...

  5. #5
    Join Date
    May 2003
    Location
    Kirkland, WA
    Posts
    4,448

  6. #6
    They might have forgotten to remove the -T
    Datums Internet Solutions, LLC
    Systems Engineering & Managed Hosting Services
    Complex Hosting Consultants

  7. #7
    Join Date
    Dec 2003
    Location
    Montreal
    Posts
    213
    I'm having the same Problem !!! I can't check Webalizer stats

    Any solution was found ?

    Thanks
    http://www.sellwebhost.com
    Web Hosting and Domain Names
    24/7 Technical support

  8. #8
    What version are you running?
    Like us on Facebook to qualify for discounts!
    http://www.sprintserve.net
    Offering: | Internap FCP Bandwidth! | Rebootless Kernel Updates! | Magento Optimized Hosting | Wordpress Hosting |
    Services: | Managed Multiple Cores 64bit Servers | Server Management |

  9. #9
    Join Date
    Dec 2003
    Location
    Montreal
    Posts
    213
    Never mind ! For some reason it worked this morning ! I think cpanel corrected their update
    http://www.sellwebhost.com
    Web Hosting and Domain Names
    24/7 Technical support

  10. #10
    Join Date
    Jun 2003
    Location
    Las Vegas, NV
    Posts
    842
    I'm seeing the same thing on one of my servers as well - i'm doing a /scripts/upcp now, lets see if that solves it.
    Rob Tyree
    Versaweb - DDoS Protected Cloud and Dedicated Server Hosting
    Fiberhub - SAS70 Type-II Colocation in Las Vegas and Seattle

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •