Results 1 to 7 of 7
  1. #1

    * Mysql Problem Syntax

    I have root access to a linux box with red hat, php and mysql. now i'm trying to install a picture program that i purchased called i-rater. Now i've done everything properly concerning the instructions and with the php but when it's time to install the databases from install.sql that's where there's a problem.

    It tells me to install the install.sql by doing the following:

    4. Install MySQL tables from admin/sql/install.sql.

    mysql platinum < admin/sql/install.sql
    (where platinum is your data base name )


    mysql> source admin/sql/install.sql

    I did the first syntax in which I got the error:

    ERROR 1045: Access denied for user: [email protected]' (Using password: NO)

    Then I tried the other one in which I have to connect to mysql.. This is what I recieved: ERROR 1046: No Database Selected

    So how do i select the datase in the second code? Or how do I do it with the first one? Please help! Thanks

  2. #2
    Join Date
    Dec 2003

    mysql -p platinum < admin/sql/install.sql

    This will prompt you for the mysql root password

  3. #3
    Join Date
    Jan 2004
    South East U.K.
    mysql -u user -p platinum
    mysql < admin/sql/install.sql

    These are the 2 pages I figured this out from, you might want to double check

  4. #4
    Ok i did the following:
    mysql -uroot -p123qweasd platinum < admin/sql/install.sql

    and I dont knw if it worked or not but it just jumped back tot he normal root# thingy. Is there anyway where I can check if it worked or not? Also when I try and view the main page or the control panel it gives me the following error:

    You have an error in your SQL syntax near '' at line 8You have an error in your SQL syntax near ') ' at line 10

    the slightest help is appreciated! Thank YOU!

  5. #5
    Join Date
    Aug 2002
    ^^ It's likely installed, also thanks for perhaps giving us your root password (I know it doesn't look real but i've seen stupider passwords )

  6. #6
    Join Date
    Dec 2003
    Your best bet is to go back to the author / helpdesk etc...

    The SQL script has obviously run as it's not produced an error, it would have been helpful if the SQL script had produced a confirmation message though.

    The messages you posted suggest a possible problem in the embedded SQL in the PHP code, so you'd really need someone who knows the system to offer advise

  7. #7
    Join Date
    Feb 2004
    Hi SteRal,

    1.[ For first error] you have given password in mysql which includes special character.
    Solution: reset the passwd which does not have special character. to reset passwd:command

    first stop mysql.

    mysql -u root mysql UPDATE user SET Password=PASSWORD('new_password') WHERE user='root';

    2.To select a database use:

    mysql> use databasename



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts