Results 1 to 6 of 6

Thread: DNS Problem...

  1. #1
    Join Date
    Jan 2004

    DNS Problem...

    Hi Friends,

    I have a starnge problem.

    Am using RH9.0 and am using the server for a local lan for sharing the internet thru IP forwarding..

    I have the following lines in my rc.local file..

    echo 1 > /proc/sys/net/ipv4/ip_forward
    #iptables -A POSTROUTING -t nat -o etho -j MASQUERADE

    after which am able to pig to any daman ip on the internet from the client machines, but am not able to browse from the client machies.. I use windows 2000 prof. as client machines..

    Can some one help me with this ?


  2. #2
    Have your client machine got any DNS settings in them - if not you have two options:

    1) Copy in the DNS server addresses that your ISP has given you


    2) Run a DNS server on your RH9 box and put that IP in

    If you don't know what you're doing then option 1 is easiest - just look at what server addresses are in /etc/resolv.conf on the RH9 box and then copy them into your win2k boxes.

    Also, rather than putting the echo... command in rc.local it would be better to edit the line in /etc/sysctl.conf that way if you restart your network interfaces (which seems to happen every once in a while automatically) you don't have to run the echo manually to make it start working again.

  3. #3
    Join Date
    Jan 2004

    same ips

    I have the same IP's of DNS on both the Server and clients DNS settings..

    Here are the setting like what i have on my server..

    It's on eth0

    IP :

    and on eth1


    with the DNS as

    and on each of client machines with a network of 192.168.0.X gateway is set to

    Strangely am abnle to ping to any IP on the internet, but still am not able to browse on the client network..


  4. #4
    Firstly you shouldn't have that gateway on eth1, it isn't needed and actually breaks the rules as the gateway should be within the same subnet as your IP address.

    What happens if from a client machine you do: ping rather than pinging IP addresses.

    If that works then DNS isn't the problem, in which case you need to look for any proxy settings that may be sitting in the client machines that aren't needed or if a setting is in the server that is needed and should go into the clients (I am assuming the server can browse at the moment).

  5. #5
    Join Date
    Jan 2004

    what needs to be done... ?

    Hi Alex,

    Thanks fo rthe info.

    Now i have a few questions again.

    1. What should be the gatway of the eth1 ?

    2. When i say ping instead of the IP it says host cannot be found.., so i guess it's the problem with the DNS.

    3. There are no proxy settings sitting on the clients machine.. actually and everything is taken care ..

    Can you check your PM on WHT


  6. #6
    eth1 doesn't need a gateway - just leave it blank.

    I am assuming you can do a dns lookup from the RH9 box, to do a test type (without quotes): 'nslookup' and see what gets returned. An example (from my server) of what you should see is:

    [[email protected] rebuke]$ nslookup

    Non-authoritative answer: canonical name =

    Note down the address that is given at the beginning, and assuming you are getting a result check that this is one of the addresses that is in your windows machines as DNS servers.

    If that is all correct then I can only think you have some firewall rules somewhere that are affecting your setup - although by default on RH9 iptables should not affect outbound traffic, only inbound stuff.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts